summaryrefslogtreecommitdiff
path: root/net-dns/knot-resolver/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-16 19:53:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-16 19:53:15 +0100
commit3108ce8586e6da41676fd6bed4101da8f4af8e31 (patch)
treee4615a7e9e6c30870f9dbd61f413dc0782b3b7af /net-dns/knot-resolver/files
parentb45619404fe758cf9245826fe1ffb4d6c4e767de (diff)
gentoo auto-resync : 16:10:2022 - 19:53:15
Diffstat (limited to 'net-dns/knot-resolver/files')
-rw-r--r--net-dns/knot-resolver/files/knot-resolver-5.5.3-docdir.patch32
-rw-r--r--net-dns/knot-resolver/files/knot-resolver-5.5.3-nghttp-openssl.patch38
2 files changed, 70 insertions, 0 deletions
diff --git a/net-dns/knot-resolver/files/knot-resolver-5.5.3-docdir.patch b/net-dns/knot-resolver/files/knot-resolver-5.5.3-docdir.patch
new file mode 100644
index 000000000000..d75b98c3acca
--- /dev/null
+++ b/net-dns/knot-resolver/files/knot-resolver-5.5.3-docdir.patch
@@ -0,0 +1,32 @@
+From 4086abfd85e0bacc027ac1773d524093387265f9 Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matthew@gentoo.org>
+Date: Sun, 16 Oct 2022 13:49:25 +0100
+Subject: [PATCH] build: docdir option
+
+--- a/meson.build
++++ b/meson.build
+@@ -46,7 +46,7 @@ endif
+ ## Paths
+ prefix = get_option('prefix')
+ data_dir = prefix / get_option('datadir') / 'knot-resolver'
+-doc_dir = prefix / get_option('datadir') / 'doc' / 'knot-resolver'
++doc_dir = get_option('docdir')
+ info_dir = prefix / get_option('datadir') / 'info'
+ examples_dir = doc_dir / 'examples'
+ etc_dir = prefix / get_option('sysconfdir') / 'knot-resolver'
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,6 +1,13 @@
+ # Configuration options
+ # SPDX-License-Identifier: GPL-3.0-or-later
+
++option(
++ 'docdir',
++ type: 'string',
++ value: '/usr/share/doc/knot-resolver',
++ description: 'path to store documentation',
++)
++
+ option(
+ 'keyfile_default',
+ type: 'string',
diff --git a/net-dns/knot-resolver/files/knot-resolver-5.5.3-nghttp-openssl.patch b/net-dns/knot-resolver/files/knot-resolver-5.5.3-nghttp-openssl.patch
new file mode 100644
index 000000000000..49340be1506c
--- /dev/null
+++ b/net-dns/knot-resolver/files/knot-resolver-5.5.3-nghttp-openssl.patch
@@ -0,0 +1,38 @@
+From 30087f85bb8d19586350c2a64648c0578c5c096c Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matthew@gentoo.org>
+Date: Sun, 16 Oct 2022 13:44:40 +0100
+Subject: [PATCH] build: Add nghttp2 and openssl options
+
+--- a/meson.build
++++ b/meson.build
+@@ -87,8 +87,8 @@ group = get_option('group')
+
+ ## Optional dependencies
+ message('--- optional dependencies ---')
+-nghttp2 = dependency('libnghttp2', required: false)
+-openssl = dependency('openssl', required: false)
++nghttp2 = dependency('libnghttp2', required: get_option('nghttp2'))
++openssl = dependency('openssl', required: get_option('openssl'))
+
+ have_asprintf = meson.get_compiler('c').has_function('asprintf',
+ prefix: '#define _GNU_SOURCE\n#include <stdio.h>')
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -205,3 +205,17 @@ option(
+ value: 'auto',
+ description: 'cmocka unit tests',
+ )
++
++option(
++ 'nghttp2',
++ type: 'feature',
++ value: 'auto',
++ description: 'dns over https support',
++)
++
++option(
++ 'openssl',
++ type: 'feature',
++ value: 'auto',
++ description: 'auxiliary debug library for http module',
++)