summaryrefslogtreecommitdiff
path: root/net-dns/https_dns_proxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-dns/https_dns_proxy
reinit the tree, so we can have metadata
Diffstat (limited to 'net-dns/https_dns_proxy')
-rw-r--r--net-dns/https_dns_proxy/Manifest2
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild27
-rw-r--r--net-dns/https_dns_proxy/metadata.xml11
3 files changed, 40 insertions, 0 deletions
diff --git a/net-dns/https_dns_proxy/Manifest b/net-dns/https_dns_proxy/Manifest
new file mode 100644
index 000000000000..e65802e641df
--- /dev/null
+++ b/net-dns/https_dns_proxy/Manifest
@@ -0,0 +1,2 @@
+EBUILD https_dns_proxy-9999.ebuild 552 SHA256 ef1716adeeb20e942f2ffb688eecd842eeab44a7bf357b288f240e73f8c19089 SHA512 675c06e8c2fdd4bcedf7cb5cc3878ce7755a78487575d00007fb549f90f5688adf99b10adf01ffadaa192cd960e4d275887fcad4f9b32e44bffcb9989d51268b WHIRLPOOL fb04269d0c642bad779212106e9114f700adb88551eeb5660f0d9fbc547084c2add6927cb7b76f78271bc38b79b3ddd1dfd73f98c15236259fdf264b80ff33e9
+MISC metadata.xml 337 SHA256 573ac7544bd6383db8622cca6cf745541f882e3c15e0d08a9088c0c4eedb87a3 SHA512 ae079152dd3fef075e6880d70295773e03758f7c1b709efd0640672631968706d5c366b4ccde498806491069861d6bc5344b0d3a2c9b7b5f0dacebe19ff4b444 WHIRLPOOL 05fd492516df79f445e34936098814530162572faed49f37d8a23b79d876c79f10c83970597d2fce95aa777b723ca2d4655e5e7999df56379a87cd2800a88945
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
new file mode 100644
index 000000000000..f409ce890da1
--- /dev/null
+++ b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3 cmake-utils
+
+DESCRIPTION="A lightweight DNS-over-HTTPS proxy."
+HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
+EGIT_REPO_URI="https://github.com/aarond10/${PN}.git"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-libs/libev
+ net-dns/c-ares
+ >=net-misc/curl-7.53.0[http2,ssl]
+ "
+RDEPEND="${DEPEND}"
+
+src_install(){
+ cmake-utils_src_install
+ exeinto /usr/bin
+ doexe "${S}_build/https_dns_proxy"
+}
diff --git a/net-dns/https_dns_proxy/metadata.xml b/net-dns/https_dns_proxy/metadata.xml
new file mode 100644
index 000000000000..3f5fcedb56b1
--- /dev/null
+++ b/net-dns/https_dns_proxy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ryao@gentoo.org</email>
+ <name>Richard Yao</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">wrouesnel/dns-over-https-proxy</remote-id>
+ </upstream>
+</pkgmetadata>