summaryrefslogtreecommitdiff
path: root/net-dns/getdns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /net-dns/getdns
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'net-dns/getdns')
-rw-r--r--net-dns/getdns/Manifest5
-rw-r--r--net-dns/getdns/files/stubby.confd4
-rwxr-xr-xnet-dns/getdns/files/stubby.initd21
-rw-r--r--net-dns/getdns/getdns-1.4.1.ebuild66
-rw-r--r--net-dns/getdns/metadata.xml21
5 files changed, 117 insertions, 0 deletions
diff --git a/net-dns/getdns/Manifest b/net-dns/getdns/Manifest
new file mode 100644
index 000000000000..3a6b3893429a
--- /dev/null
+++ b/net-dns/getdns/Manifest
@@ -0,0 +1,5 @@
+AUX stubby.confd 123 BLAKE2B f948e41ad6acbf19bda137fb26fc284651681b45ec7421160946c86c97089fb411cf3611853dbf9c92dfdde26814eab085cb971b552d5459ebe99828b4e4d278 SHA512 698cd718f3acf4a99399a57a7eb80e93ee50489eb1e31ffd485312b86307ece05775f4bbe9a49b3117f6a96f507e6314d9d47a7c23c828a5b231ab8e770e8bef
+AUX stubby.initd 462 BLAKE2B 0825fe3762256377c5ce6c66e982f67fee0edf9b685b51ae8538af0592966f26388776fe079aed31983a110c09b230b7dabada4949a105c83700c699fdd2c82c SHA512 26932bf845e02117bc41e907e0877b0231a9bde83cdea605f5b7a8ea514aea27a412d110e591ce794bd1574ce871a1d4b02847af4f1e58e249432007b7a769d0
+DIST getdns-1.4.1.tar.gz 1055348 BLAKE2B 3b664e669327f5d866e6b40defb3ee4b62a09be228cac726478dbc6843b64aaf49faa328e1013700daf554c4df1144a8d56cca9d9405057d35b89b8ab7ae1f43 SHA512 b15da1c898d4bb4e5dcd93b47f481696dd456d8a841b02122c46035f3da27ca13b5513e7b6a00e943d1a5f5cec8c5ce1f13729d3ce0c887d8faa31d201864b27
+EBUILD getdns-1.4.1.ebuild 1586 BLAKE2B 5d6662e6e37f8aa35f2ffcdb4a4085cce961de9bea8de5be81ccbff6f8edd3e5251eecda8f60e0fdc625e2e1c18874ebdf2cba2629b93f88cb46eb4e71899e32 SHA512 786ae123546cc5df67f13ad902e6c9523b3fe2cb7800cc79afd7b1bbad87c94ee8af4aec824698dee711ba42c37fbfabcdae3a0fe92539ca20660d6476b25f96
+MISC metadata.xml 857 BLAKE2B 25a516aa2d67d8ce5961b8a99d71f355fb99f163ccbbeee29c7c505729ba76735b7d6977f5aa8cb60b328943c715a9dbb4652b4e3133009e220c1db0de9cf875 SHA512 33065cbe6ddfa2b0382d55a0441a819f2d4795cd458fe6b53d4da444b9542d49781d7dcf7b11615c46e3157bdc1deab89c765a24ee100c67687fb64cd2099bd1
diff --git a/net-dns/getdns/files/stubby.confd b/net-dns/getdns/files/stubby.confd
new file mode 100644
index 000000000000..b862ea4a40d7
--- /dev/null
+++ b/net-dns/getdns/files/stubby.confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/stubby: config file for /etc/init.d/stubby
+
+# See stubby -h for possible options to put here.
+STUBBY_OPTS=""
diff --git a/net-dns/getdns/files/stubby.initd b/net-dns/getdns/files/stubby.initd
new file mode 100755
index 000000000000..170db9be07fe
--- /dev/null
+++ b/net-dns/getdns/files/stubby.initd
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+command="capsh"
+command_args="--inh=cap_net_bind_service --user=stubby -- -c '/usr/bin/stubby -g ${STUBBY_OPTS}'"
+pidfile="/var/run/stubby/stubby.pid"
+name="DNS Privacy Daemon"
+
+depend()
+{
+ provide dns
+ need localmount net
+ after bootmisc
+ use logger
+}
+
+start_pre()
+{
+ checkpath -d -m 1755 -o stubby:stubby /var/run/stubby
+}
diff --git a/net-dns/getdns/getdns-1.4.1.ebuild b/net-dns/getdns/getdns-1.4.1.ebuild
new file mode 100644
index 000000000000..13ab6bc3b156
--- /dev/null
+++ b/net-dns/getdns/getdns-1.4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user fcaps
+
+DESCRIPTION="Modern asynchronous DNS API"
+HOMEPAGE="https://getdnsapi.net/"
+SRC_URI="https://getdnsapi.net/releases/${P//./-}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="stubby +getdns_query +getdns_server_mon libressl +idn +unbound libevent libev libuv +threads"
+
+DEPEND="
+ dev-libs/libyaml:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ idn? ( net-dns/libidn2:= )
+ unbound? ( >=net-dns/unbound-1.4.16:= )
+ libevent? ( dev-libs/libevent:= )
+ libev? ( dev-libs/libev:= )
+ libuv? ( dev-libs/libuv:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --runstatedir=/var/run \
+ --with-piddir=/var/run/stubby \
+ $(use_with stubby) \
+ $(use_with getdns_query) \
+ $(use_with getdns_server_mon) \
+ $(use_with idn libidn2) \
+ --without-libidn \
+ $(use_with unbound libunbound) \
+ $(use_with libevent) \
+ $(use_with libev) \
+ $(use_with libuv) \
+ $(use_with threads libpthread)
+}
+
+src_install() {
+ default
+ if use stubby; then
+ newinitd "${FILESDIR}"/stubby.initd stubby
+ newconfd "${FILESDIR}"/stubby.confd stubby
+ fi
+}
+
+pkg_postinst() {
+ if use stubby; then
+ enewgroup stubby
+ enewuser stubby -1 -1 -1 stubby
+ fcaps cap_net_bind_service=ei /usr/bin/stubby
+ fi
+
+ if has_version <dev-libs/libressl-2.7.0; then
+ ewarn "BEWARE: dev-libs/libressl prior to 2.7 does NOT check TLS certificates."
+ if use stubby; then
+ ewarn "You will NOT be able to use strict profile in Stubby."
+ fi
+ fi
+}
diff --git a/net-dns/getdns/metadata.xml b/net-dns/getdns/metadata.xml
new file mode 100644
index 000000000000..58710c149310
--- /dev/null
+++ b/net-dns/getdns/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@retornaz.com</email>
+ <name>Quentin Retornaz</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <use>
+ <flag name="stubby">Add Stubby DNS Privacy Deamon</flag>
+ <flag name="getdns_query">Add getdns_query tool</flag>
+ <flag name="getdns_server_mon">Add getdns_server_mon tool</flag>
+ <flag name="unbound">Enable <pkg>net-dns/unbound</pkg> libraries support</flag>
+ <flag name="libevent">Enable <pkg>dev-libs/libevent</pkg> support</flag>
+ <flag name="libev">Enable <pkg>dev-libs/libev</pkg> support</flag>
+ <flag name="libuv">Enable <pkg>dev-libs/libuv</pkg> support</flag>
+ </use>
+</pkgmetadata>