summaryrefslogtreecommitdiff
path: root/net-dns/getdns/getdns-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /net-dns/getdns/getdns-1.5.1.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'net-dns/getdns/getdns-1.5.1.ebuild')
-rw-r--r--net-dns/getdns/getdns-1.5.1.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/net-dns/getdns/getdns-1.5.1.ebuild b/net-dns/getdns/getdns-1.5.1.ebuild
deleted file mode 100644
index 9333b5ff65f1..000000000000
--- a/net-dns/getdns/getdns-1.5.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit fcaps systemd user tmpfiles
-
-DESCRIPTION="Modern asynchronous DNS API"
-HOMEPAGE="https://getdnsapi.net/"
-SRC_URI="https://getdnsapi.net/releases/${P//./-}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +getdns-query +getdns-server-mon +idn libev libevent libuv static-libs stubby +threads +unbound"
-
-# https://bugs.gentoo.org/661760
-# https://github.com/getdnsapi/getdns/issues/407
-RESTRICT="test"
-
-DEPEND="
- dev-libs/libbsd:=
- dev-libs/libyaml:=
- idn? ( net-dns/libidn2:= )
- dev-libs/openssl:0=
- libev? ( dev-libs/libev:= )
- libevent? ( dev-libs/libevent:= )
- libuv? ( dev-libs/libuv:= )
- unbound? ( >=net-dns/unbound-1.4.16:= )
-"
-RDEPEND="
- ${DEPEND}
- stubby? ( sys-libs/libcap:= )
-"
-BDEPEND="
- doc? ( app-doc/doxygen )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-1.4.2-stubby.service.patch" )
-
-src_configure() {
- econf \
- --runstatedir=/var/run \
- $(use_enable static-libs static) \
- $(use_with getdns-query getdns_query) \
- $(use_with getdns-server-mon getdns_server_mon) \
- $(use_with idn libidn2) \
- $(use_with libev) \
- $(use_with libevent) \
- $(use_with libuv) \
- $(use_with stubby) \
- $(use_with threads libpthread) \
- $(use_with unbound libunbound) \
- --without-libidn \
- --with-piddir=/var/run/stubby
-}
-
-src_install() {
- default
- if use stubby; then
- newinitd "${FILESDIR}"/stubby.initd-r1 stubby
- newconfd "${FILESDIR}"/stubby.confd-r1 stubby
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/stubby.logrotate stubby
- systemd_dounit "${S}"/stubby/systemd/stubby.service
- dotmpfiles "${S}"/stubby/systemd/stubby.conf
- fi
-}
-
-pkg_postinst() {
- if use stubby; then
- enewgroup stubby
- enewuser stubby -1 -1 -1 stubby
- fcaps cap_net_bind_service=ei /usr/bin/stubby
- fi
-}