summaryrefslogtreecommitdiff
path: root/net-dns/dnswalk/dnswalk-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-dns/dnswalk/dnswalk-2.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-dns/dnswalk/dnswalk-2.0.2.ebuild')
-rw-r--r--net-dns/dnswalk/dnswalk-2.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-dns/dnswalk/dnswalk-2.0.2.ebuild b/net-dns/dnswalk/dnswalk-2.0.2.ebuild
new file mode 100644
index 000000000000..561f12577ffa
--- /dev/null
+++ b/net-dns/dnswalk/dnswalk-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="dnswalk is a DNS database debugger"
+HOMEPAGE="https://sourceforge.net/projects/dnswalk/"
+SRC_URI="mirror://sourceforge/dnswalk/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND=">=dev-perl/Net-DNS-0.12"
+
+S=${WORKDIR}
+
+src_prepare() {
+ sed -i 's:#!/usr/contrib/bin/perl:#!'"${EPREFIX}"'/usr/bin/perl:' dnswalk
+}
+
+src_install () {
+ dobin dnswalk
+
+ dodoc CHANGES README TODO \
+ do-dnswalk makereports sendreports rfc1912.txt dnswalk.errors
+ doman dnswalk.1
+}