summaryrefslogtreecommitdiff
path: root/net-dns/c-ares
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /net-dns/c-ares
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'net-dns/c-ares')
-rw-r--r--net-dns/c-ares/Manifest2
-rw-r--r--net-dns/c-ares/c-ares-1.18.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index 07112387f2a4..d9c59616d574 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -1,3 +1,5 @@
DIST c-ares-1.17.2.tar.gz 1538276 BLAKE2B c6f5ad65ca75f8467b624daf3caaee2f35d6e4714ce46ebe1bbf79447feecf8615915b00fa5e7bd1e97c6232864e06c53a792fbadf36a5399883529769273e24 SHA512 f625e0ef8508af6475d3e83b51ab29be8a4878e2a87e7f518bea046b76a74bfde7043ca6ec2a9e714c898ab9e5d4a5a678c3347a9f9eb68980438f7ca8ae3fc8
+DIST c-ares-1.18.1.tar.gz 1560165 BLAKE2B c03a572726c6bbb24a3e4773673d0c87f4833bb9582aed57a424eea8c965beb6e232f502b61922b124d37403d91ebfefe0db7373673fc22e0d752c4e5036eb07 SHA512 1276ec0799916019f8c0af6b55a139701bd15e0ca4a00811d07963893978bc96c107b980f0fd49f81aa70bc8b3b8cd671195ba357c390772d4c2c5643c50c5a5
EBUILD c-ares-1.17.2.ebuild 1646 BLAKE2B 4b256e6fd8642b2e08ea5eea9d386aa48adef0d972124cee10c2a631d1aabb96eb83705dbd0b76072eac147fcba2257be7116dafd0afb0b30d488b9a5d425028 SHA512 7691c1b7e12c2b1695cb17f14804720445f95b61653880927274ece48edaefb2208678c88abacb6d3bf88c2cb4ddd3a3e393fc1c7439efed08f9ca8a5383b52c
+EBUILD c-ares-1.18.1.ebuild 1654 BLAKE2B 64b56aacfd7f07bd50fd47a79451b88c3dc278f021e63b92bc00a24207ecddb0230a6b38b63310836c1eb724e9321959c1a65e57be20deb502fab74bc52f4190 SHA512 6850dcf7123fd26e1971bbd76c1fba2381bd0cf5fd747ce3bf23b5a87b7c72ff0b1422ac3ebecd10c52701a125263d02b99122bc4f0abc8fa6cae5045cc42381
MISC metadata.xml 340 BLAKE2B 9193fb644d2dc9bd9e81cdbbc9f8f7617a99a2c6bfcbd4f61a08b2ecec349f9cdd572a5fe55e1704744e4b17a2e81cd49ee46838cef22856f25012b35714ffb6 SHA512 1d6b287e44ac9e60db23b074af2f8cf7894133138e28c15ae300b37f0ceedf4d57b604a1d05f711f46d9db7b6519a597a00b725f8bf151d386bf5670b42bbf4e
diff --git a/net-dns/c-ares/c-ares-1.18.1.ebuild b/net-dns/c-ares/c-ares-1.18.1.ebuild
new file mode 100644
index 000000000000..25030c0afdae
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.18.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.haxx.se/"
+SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+multilib_src_configure() {
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ ax_cv_uts_namespace=no \
+ ax_cv_user_namespace=no \
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}")) || die "arestest failed!"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}