summaryrefslogtreecommitdiff
path: root/net-dialup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 23:29:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 23:29:13 +0100
commitb544d842bfe55df1b59d40fb8059d5d240e4f42b (patch)
tree092145f89b76ccd50aba38348cb99b802227f5ae /net-dialup
parent20c20eb967a638c833aae1462f149894b2dbd811 (diff)
gentoo auto-resync : 26:09:2023 - 23:29:12
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/Manifest.gzbin5228 -> 5232 bytes
-rw-r--r--net-dialup/ppp/Manifest1
-rw-r--r--net-dialup/ppp/ppp-2.5.0-r5.ebuild136
3 files changed, 137 insertions, 0 deletions
diff --git a/net-dialup/Manifest.gz b/net-dialup/Manifest.gz
index 0863ccc6d2f9..dc304367fca9 100644
--- a/net-dialup/Manifest.gz
+++ b/net-dialup/Manifest.gz
Binary files differ
diff --git a/net-dialup/ppp/Manifest b/net-dialup/ppp/Manifest
index 747d2ab13eb3..d10a5fcecf1a 100644
--- a/net-dialup/ppp/Manifest
+++ b/net-dialup/ppp/Manifest
@@ -17,4 +17,5 @@ EBUILD ppp-2.4.9-r9.ebuild 7866 BLAKE2B e2f6012eb93f27271c775b75fa52e0d1307adee4
EBUILD ppp-2.5.0-r2.ebuild 3452 BLAKE2B 59ae8469e5a95a2c68364a7a487e45e9e101cb342456e7a60c4abcb5db0e4f5207a2227a88ad9ae6438f1c655668294e58a9d8c821e52b03dc9e2a0200ba29d8 SHA512 bad4912c44bde1a66351d8e17e0c48cf6c1e0b800f6205e107ee78b49a84fc24bbe98356c0dffbd59af81abd08e0571d113aad50e4864fc1062a47e58d5effe4
EBUILD ppp-2.5.0-r3.ebuild 3489 BLAKE2B 3a0eab803000ef507d175ae4c5d1d2b04028b5bd8083678d15f3856b426b91b716b7887c8c5c8e7c783ddece5db026b2727666b34e85ad4a30554b35b12e8ec7 SHA512 7ae193c9392ba7127e001725fa991f01fafd06bc01f2a099a1507d308e938e0fb0692f7f92f3c8a7895e52dc126b26d1526dee2480900fe7029390ccf3fa1551
EBUILD ppp-2.5.0-r4.ebuild 3551 BLAKE2B befe544b9b7f070d124e8c48c87a625de5db434bde110411b5e9c65068ddca8e1914c8e831588a2cc65431ff771d5b375f97cfc6da6c50324b9381c4510f0e99 SHA512 189cc552fea3f0bacc030bfa595f474df865cc7c8d73b230af2504dc81234844c976f775e29ed7010cefc81cb7fea9233f837a8f880ba3b0e85389ac0b8d3f08
+EBUILD ppp-2.5.0-r5.ebuild 4040 BLAKE2B d77bb2bb8c383ec2beb0a48a85b5a2be4eb1f38337a1ac1a3cc23364fce6b8dae9f69a68d649207352b8a4d6b4b4c28c9817534b2bce26842145e0ec33d2ca24 SHA512 7dddc6ccc1cffa69ca421e245de6c55a946da8efd6d13e8a58caffaaf1eb52017fb4b8794775bb89c503a54a180f48c806151535b1659b4ec120b2bbe0ce608d
MISC metadata.xml 1002 BLAKE2B 9ce1dcb685ed4f0d6dfe2e6c885b8feca8d81fd1fea5bde44a40900d65b2f9e9a45bd03f3708d4969c51880bb7ffb791bfbc972d4ec06a3124c4215e2b66424b SHA512 cdfa0b69fab5a530b36093bc84c352da1f8acbdf3d31e2b9a4d58bde7dc7bbbce9c54000d9f874eac2ddcc803bafc89ea2a74b03cac23dca295815ece6cb2157
diff --git a/net-dialup/ppp/ppp-2.5.0-r5.ebuild b/net-dialup/ppp/ppp-2.5.0-r5.ebuild
new file mode 100644
index 000000000000..a97d33222c22
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.5.0-r5.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info pam tmpfiles
+
+DESCRIPTION="Point-to-Point Protocol (PPP)"
+HOMEPAGE="https://ppp.samba.org/"
+SRC_URI="
+ https://download.samba.org/pub/ppp/${P}.tar.gz
+ https://raw.githubusercontent.com/ppp-project/ppp/${P}/contrib/pppgetpass/pppgetpass.8
+"
+
+LICENSE="BSD GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="activefilter atm gtk pam selinux systemd"
+
+DEPEND="
+ dev-libs/openssl:0=
+ virtual/libcrypt:=
+ activefilter? ( net-libs/libpcap )
+ atm? ( net-dialup/linux-atm )
+ gtk? ( x11-libs/gtk+:2 )
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="
+ ${DEPEND}
+ !<net-misc/netifrc-0.7.1-r2
+ selinux? ( sec-policy/selinux-ppp )
+"
+BDEPEND="virtual/pkgconfig"
+PDEPEND="net-dialup/ppp-scripts"
+
+PATCHES=(
+ "${FILESDIR}"/ppp-2.5.0-passwordfd-read-early.patch
+ "${FILESDIR}"/ppp-2.5.0-pidfile.patch
+ "${FILESDIR}"/${P}-radiusclient.conf-parsing.patch
+)
+
+pkg_setup() {
+ local CONFIG_CHECK="~PPP ~PPP_ASYNC ~PPP_SYNC_TTY"
+ local ERROR_PPP="CONFIG_PPP:\t missing PPP support (REQUIRED)"
+ local ERROR_PPP_ASYNC="CONFIG_PPP_ASYNC:\t missing asynchronous serial line discipline"
+ ERROR_PPP_ASYNC+=" (optional, but highly recommended)"
+ local WARNING_PPP_SYNC_TTY="CONFIG_PPP_SYNC_TTY:\t missing synchronous serial line discipline"
+ WARNING_PPP_SYNC_TTY+=" (optional; used by 'sync' pppd option)"
+ if use activefilter ; then
+ CONFIG_CHECK+=" ~PPP_FILTER"
+ local ERROR_PPP_FILTER="CONFIG_PPP_FILTER:\t missing PPP filtering support (REQUIRED)"
+ fi
+ CONFIG_CHECK+=" ~PPP_DEFLATE ~PPP_BSDCOMP ~PPP_MPPE"
+ local ERROR_PPP_DEFLATE="CONFIG_PPP_DEFLATE:\t missing Deflate compression (optional, but highly recommended)"
+ local ERROR_PPP_BSDCOMP="CONFIG_PPP_BSDCOMP:\t missing BSD-Compress compression (optional, but highly recommended)"
+ local WARNING_PPP_MPPE="CONFIG_PPP_MPPE:\t missing MPPE encryption (optional, mostly used by PPTP links)"
+ CONFIG_CHECK+=" ~PPPOE ~PACKET"
+ local WARNING_PPPOE="CONFIG_PPPOE:\t missing PPPoE support (optional, needed by pppoe plugin)"
+ local WARNING_PACKET="CONFIG_PACKET:\t missing AF_PACKET support (optional, used by pppoe plugin)"
+ if use atm ; then
+ CONFIG_CHECK+=" ~PPPOATM"
+ local WARNING_PPPOATM="CONFIG_PPPOATM:\t missing PPPoA support (optional, needed by pppoatm plugin)"
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Set the right paths in radiusclient.conf
+ sed -e "s:/usr/local/etc:/etc:" \
+ -e "s:/usr/local/sbin:/usr/sbin:" \
+ -i pppd/plugins/radius/etc/radiusclient.conf || die
+ # Set config dir to /etc/ppp/radius
+ sed -i -e "s:/etc/radiusclient:/etc/ppp/radius:g" \
+ pppd/plugins/radius/{*.8,*.c,*.h} \
+ pppd/plugins/radius/etc/* || die
+}
+
+src_configure() {
+ local args=(
+ --localstatedir="${EPREFIX}"/var
+ --runstatedir="${EPREFIX}"/run
+ $(use_enable systemd)
+ $(use_with atm)
+ $(use_with pam)
+ $(use_with activefilter pcap)
+ $(use_with gtk)
+ --enable-cbcp
+ )
+ econf "${args[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+
+ if use pam; then
+ pamd_mimic_system ppp auth account session
+ fi
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/modules.ppp" ppp.conf
+
+ dosbin scripts/p{on,off,log}
+ doman scripts/pon.1
+ dosym pon.1 /usr/share/man/man1/poff.1
+ dosym pon.1 /usr/share/man/man1/plog.1
+
+ # Adding misc. specialized scripts to doc dir
+ dodoc -r scripts
+
+ if use gtk ; then
+ dosbin contrib/pppgetpass/pppgetpass.{gtk,vt}
+ newsbin contrib/pppgetpass/pppgetpass.sh pppgetpass
+ else
+ newsbin contrib/pppgetpass/pppgetpass.vt pppgetpass
+ fi
+
+ newtmpfiles "${FILESDIR}/pppd.tmpfiles" pppd.conf
+
+ # Missing from upstream tarball
+ # https://github.com/ppp-project/ppp/pull/412
+ #doman contrib/pppgetpass/pppgetpass.8
+ doman "${DISTDIR}/pppgetpass.8"
+
+ insinto /etc/ppp/radius
+ doins pppd/plugins/radius/etc/{dictionary*,issue,port-id-map,radiusclient.conf,realms,servers}
+}
+
+pkg_postinst() {
+ tmpfiles_process pppd.conf
+}