summaryrefslogtreecommitdiff
path: root/net-dialup/ueagle-atm/ueagle-atm-1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-dialup/ueagle-atm/ueagle-atm-1.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-dialup/ueagle-atm/ueagle-atm-1.1-r3.ebuild')
-rw-r--r--net-dialup/ueagle-atm/ueagle-atm-1.1-r3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-dialup/ueagle-atm/ueagle-atm-1.1-r3.ebuild b/net-dialup/ueagle-atm/ueagle-atm-1.1-r3.ebuild
new file mode 100644
index 000000000000..6143b28417a5
--- /dev/null
+++ b/net-dialup/ueagle-atm/ueagle-atm-1.1-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils linux-info
+
+DESCRIPTION="Firmware and configuration instructions for ADI 930/Eagle USB ADSL Modem driver"
+HOMEPAGE="https://gna.org/projects/ueagleatm/"
+SRC_URI="http://eagle-usb.org/ueagle-atm/non-free/ueagle-data-src-${PV}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+DEPEND=""
+RDEPEND="net-dialup/ppp
+ !sys-kernel/linux-firmware"
+
+S="${WORKDIR}/ueagle-data-src-${PV}"
+
+src_compile() {
+ emake generate
+}
+
+src_install() {
+ # Copy to the firmware directory
+ insinto /lib/firmware/ueagle-atm
+ doins build/*
+
+ # Documentation necessary to complete the setup
+ dodoc "${FILESDIR}/README"
+}
+
+pkg_postinst() {
+ # Check kernel configuration
+ local CONFIG_CHECK="~FW_LOADER ~NET ~PACKET ~ATM ~NETDEVICES ~USB_DEVICEFS ~USB_ATM ~USB_UEAGLEATM \
+ ~PPP ~PPPOATM ~PPPOE ~ATM_BR2684"
+ local WARNING_PPPOATM="CONFIG_PPPOATM:\t is not set (required for PPPoA links)"
+ local WARNING_PPPOE="CONFIG_PPPOE:\t is not set (required for PPPoE links)"
+ local WARNING_ATM_BR2684="CONFIG_ATM_BR2684:\t is not set (required for PPPoE links)"
+ check_extra_config
+ echo
+
+ # Check user-space for PPPoA support
+ if ! has_version net-dialup/ppp[atm] ; then
+ ewarn "Run the following command if connecting via PPPoA protocol:"
+ ewarn " euse -E atm && emerge net-dialup/ppp"
+ echo
+ fi
+ # Check user-space for PPPoE support
+ if ! has_version net-dialup/linux-atm ; then
+ ewarn "Run the following command if connecting via PPPoE protocol:"
+ ewarn " emerge net-dialup/linux-atm"
+ echo
+ fi
+
+ ewarn "To complete the installation, you must read the documentation in"
+ ewarn " ${ROOT}usr/share/doc/${PF}"
+}