summaryrefslogtreecommitdiff
path: root/net-dialup/freeradius-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /net-dialup/freeradius-client
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'net-dialup/freeradius-client')
-rw-r--r--net-dialup/freeradius-client/Manifest3
-rw-r--r--net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild48
-rw-r--r--net-dialup/freeradius-client/metadata.xml34
3 files changed, 72 insertions, 13 deletions
diff --git a/net-dialup/freeradius-client/Manifest b/net-dialup/freeradius-client/Manifest
index a446533d3ce4..4655e3d0fa24 100644
--- a/net-dialup/freeradius-client/Manifest
+++ b/net-dialup/freeradius-client/Manifest
@@ -1,3 +1,4 @@
DIST freeradius-client-1.1.7.tar.gz 433141 BLAKE2B 3a1ba65eb8b66d28362fd66a905af0a4e12b67e664da2c64dab87616e3787cded58d0c3bf56705bdb879d41f1a9a984cf5256b06eeb382209caebf748f679e12 SHA512 20e79ec97da79f46b334e1c2880803a692885a4038196a4d016094d349f675e2d0521d921140c5ab06703008619417f7a20d3e90cdfc7b3578faccbd232be0ce
+EBUILD freeradius-client-1.1.7-r1.ebuild 975 BLAKE2B 94b9ba767e1bdbecc90ac1de3245cf97aac3b2ea2e3a064002c2af1aa4b3f84fae2bc4d41afd456f233420fe5f6e1bc7a4096e7ef8036c3919d03d4ab9d39014 SHA512 69e680f941e69e8524bd26cdbcbeb4d3ba952ec01490a1e74094f0a716706ead3cee7e246273786efd293d2422e57b2dcaf441331eda4d586bc4ead4333fef00
EBUILD freeradius-client-1.1.7.ebuild 836 BLAKE2B 38271f1900af8aaf48a0fdfb5247ff33660c52086bb4c92065b9cb30669d54e3fc3d686f814c09a55271fcae3db4f6fc4572f2540bffb4c134b874f0574f88cd SHA512 718cba62d2996bdbd4c38bca123e35862ea99a34f08b66c61523498c1d3efcfde8eef41b9c71846b5e2973875c86f1c8404ea9ad14c91a073e4d3c6ba0ce6dff
-MISC metadata.xml 711 BLAKE2B 9c8b62b863c724f5420b360f919af5b42e7a8d7951a43ba79c871ff54fb88ac3599df12043f792b27cc33fa6ddf71d16c688f90a128a61a2a723812a994544e1 SHA512 9e0758dd57ba13e42d5517aba8c7a6a6f5ede66f0fc6fa62a2a361ab7ba03058032b6a998f93ee24d3ce3050f3757694d8d088c6e09754cfc0652c2b857ef3cc
+MISC metadata.xml 937 BLAKE2B dd3e76a7a6a71b1d0ad75eb4190154124c8c15c8026ee35947067fc403369a348117dbb72f3986b81234777896aeef6ebc32f6ad32e6d41ae24dc772e9f57a28 SHA512 49a0f971e1bac986e6f6dfb02370011afeda182eb733b1c11cc1307d43881fadf924af84c42d8ed44937a01faa9b5793a8ec112e87d6648ba0d1737ee4c5495d
diff --git a/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..f9ac8661b098
--- /dev/null
+++ b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="FreeRADIUS Client framework"
+HOMEPAGE="https://wiki.freeradius.org/project/Radiusclient"
+SRC_URI="ftp://ftp.freeradius.org/pub/freeradius/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="scp shadow static-libs"
+
+DEPEND="!net-dialup/radiusclient-ng"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ BUGS doc/{ChangeLog,login.example,release-method.txt,instop.html}
+ README.{radexample,rst}
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die \
+ "Renaming configure.in to configure.ac failed"
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable scp)
+ $(use_enable shadow)
+ --with-secure-path
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newdoc doc/README README.login.example
+
+ use static-libs || \
+ find "${ED}" -name '*.a' -delete
+}
diff --git a/net-dialup/freeradius-client/metadata.xml b/net-dialup/freeradius-client/metadata.xml
index 2a085401d81d..597f77ab7b7f 100644
--- a/net-dialup/freeradius-client/metadata.xml
+++ b/net-dialup/freeradius-client/metadata.xml
@@ -1,16 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>FreeRADIUS Client is a framework and library for writing
-RADIUS Clients which additionally includes radlogin, a flexible RADIUS
-aware login replacement, a command line program to send RADIUS accounting
-records, a utility allowing to send RADIUS AAA requests from command
-line or from shell scripts and a utility to query the status of a (Merit)
-RADIUS server.</longdescription>
-<use>
- <flag name="scp">Add service type hints derived from username
- prefix</flag>
- <flag name="shadow">Enable shadow password support</flag>
-</use>
+ <maintainer type="person">
+ <email>alarig@swordarmor.fr</email>
+ <name>Alarig Le Lay</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ FreeRADIUS Client is a framework and library for writing RADIUS Clients
+ which additionally includes radlogin, a flexible RADIUS aware login
+ replacement, a command line program to send RADIUS accounting records, a
+ utility allowing to send RADIUS AAA requests from command line or from
+ shell scripts and a utility to query the status of a (Merit) RADIUS
+ server.
+ </longdescription>
+ <use>
+ <flag name="scp">
+ Add service type hints derived from username prefix
+ </flag>
+ <flag name="shadow">Enable shadow password support</flag>
+ </use>
</pkgmetadata>