summaryrefslogtreecommitdiff
path: root/net-dialup/cutecom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-dialup/cutecom
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-dialup/cutecom')
-rw-r--r--net-dialup/cutecom/Manifest4
-rw-r--r--net-dialup/cutecom/cutecom-0.51.0.ebuild40
-rw-r--r--net-dialup/cutecom/metadata.xml15
3 files changed, 51 insertions, 8 deletions
diff --git a/net-dialup/cutecom/Manifest b/net-dialup/cutecom/Manifest
index c4c5a70316a0..d4510879639a 100644
--- a/net-dialup/cutecom/Manifest
+++ b/net-dialup/cutecom/Manifest
@@ -1,3 +1,5 @@
DIST cutecom-0.40.0.tar.gz 813238 BLAKE2B 2bc4f653e482e722f644dbaa0d713c3d8b6575369ad98d596843be18a37e8865857b82dcaccb52af73f3aa6e4e433ce2e43efe6d681ed558eedc468cee120827 SHA512 63df993fee01d73c40180a6b92d49e5200ae14db0275690f59ff02cfd2b6f573623cf74fb6d5dcabc292314642bb9cf2d9bd274a4094917f70418c30209bb403
+DIST cutecom-v0.51.0.tar.bz2 1296457 BLAKE2B 407bbe12fb4303e98589720c3fe9bf96a4112c816e64a3a32227d07a64c1efbb5b33c364d1f3f06ff67c9bc935c0bf62de14849b554508eaffacda1f65e7fad9 SHA512 67857977ab6444509662be4d27059e3c4cb766a69b78d806f4cd3d6cb7306d53094337fb384133a616ae397ac4d4d7c86347285a2d68f88fbf105d73ebd97731
EBUILD cutecom-0.40.0-r1.ebuild 811 BLAKE2B 01f0be2ea4c8ae05f0ef8825afb91f7110c4af1fa468e10e7f066afdd314e5683dff96c2566a75f2195bbfde2850e43905295458726614fd3df36d5d6cee981e SHA512 de15e8529b6855c7e3330dde8d893e53202fc7daab13117d51732ba8157797085a1c9caf90cb21d8ca0be6b50649e59cb6e4d4533e072be3c36d4a0ee0f7695e
-MISC metadata.xml 503 BLAKE2B b935c9a442db78b7dba2cb33446bc0b14f56760625b63f6f9d220a73f772a9e4900d18c60170004e3266052407a799d14f2ee4b6cb16a05860005fe9dc16bb90 SHA512 15d1dab579e2af2f6176b46b9c23ac621eeb302c53fd87848550e584e36a90855f6a13995fe5baecb1526485c0cefacb4dcdd426c7ea5682537bf0468dadd4f3
+EBUILD cutecom-0.51.0.ebuild 834 BLAKE2B da0ea9b416c7b5c654446ddfb8a552c4a0a70ab8ed148236ea67973bec4b8ccd5a9d070b8f52640e42d1e432010d52acdb302806490889663bc555077dd31122 SHA512 c818c194bbaf1b8310eac0d2897a8586ba9c94f3727c5973b897a9baa851f8b1680fcf9f5722752cac68e26e57fdb476f94206f880293156f379bff1937897d8
+MISC metadata.xml 518 BLAKE2B e409cc5cd2b57e810e408991786f22b93464167b4efe51374e6f4a5be8d5bf80f351ea37b3cd26080f731c53428d3046053ddb1e7192c8129d291a77c718fe76 SHA512 3641e21c8f46af695d3e11a27d3f67a6ef8670fc1d1621d253f2f0555ffc8a30762bf91513e5539177e640253c8f7ec2b574b8c2332a933150664bf2d3ad8880
diff --git a/net-dialup/cutecom/cutecom-0.51.0.ebuild b/net-dialup/cutecom/cutecom-0.51.0.ebuild
new file mode 100644
index 000000000000..7a7739601805
--- /dev/null
+++ b/net-dialup/cutecom/cutecom-0.51.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils
+
+DESCRIPTION="CuteCom is a serial terminal, like minicom, written in qt"
+HOMEPAGE="https://gitlab.com/neundorf/CuteCom"
+SRC_URI="https://gitlab.com/cutecom/cutecom/-/archive/v${PV}/cutecom-v${PV}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtserialport:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+S="${WORKDIR}/cutecom-v${PV}"
+
+src_prepare() {
+ sed -i \
+ -e '/Path/d' \
+ -e '/Terminal/s/0/false/' \
+ "${PN}.desktop" || die 'sed on desktop file failed'
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu "${PN}.desktop"
+ doicon "distribution/${PN}.png"
+}
diff --git a/net-dialup/cutecom/metadata.xml b/net-dialup/cutecom/metadata.xml
index 8ad2379909d6..107ba45773b3 100644
--- a/net-dialup/cutecom/metadata.xml
+++ b/net-dialup/cutecom/metadata.xml
@@ -1,11 +1,12 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>CuteCom is a graphical serial terminal, like minicom. It is aimed mainly at hardware
-developers or other people who need a terminal to talk to their devices.</longdescription>
- <upstream>
- <remote-id type="sourceforge">cutecom</remote-id>
- <remote-id type="github">neundorf/CuteCom</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+ <longdescription>CuteCom is a graphical serial terminal, like minicom. It is aimed mainly at hardware developers or other people who need a terminal to talk to their devices.</longdescription>
+ <upstream>
+ <remote-id type="gitlab">cutecom/cutecom</remote-id>
+ </upstream>
</pkgmetadata>