summaryrefslogtreecommitdiff
path: root/net-dialup/cutecom/cutecom-0.40.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-dialup/cutecom/cutecom-0.40.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-dialup/cutecom/cutecom-0.40.0-r1.ebuild')
-rw-r--r--net-dialup/cutecom/cutecom-0.40.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-dialup/cutecom/cutecom-0.40.0-r1.ebuild b/net-dialup/cutecom/cutecom-0.40.0-r1.ebuild
new file mode 100644
index 000000000000..325579387758
--- /dev/null
+++ b/net-dialup/cutecom/cutecom-0.40.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils
+
+DESCRIPTION="CuteCom is a serial terminal, like minicom, written in qt"
+HOMEPAGE="https://github.com/neundorf/CuteCom"
+SRC_URI="https://codeload.github.com/neundorf/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtserialport:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+S="${WORKDIR}/CuteCom-${PV}"
+
+src_prepare() {
+ sed -i \
+ -e '/Path/d' \
+ -e '/Terminal/s/0/false/' \
+ "${PN}.desktop" || die 'sed on desktop file failed'
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu "${PN}.desktop"
+ doicon "distribution/${PN}.png"
+}