summaryrefslogtreecommitdiff
path: root/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild')
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild b/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
index 321e1e6f6d8f..9aad51163a13 100644
--- a/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
@@ -15,11 +15,12 @@ SRC_URI="https://cdn.zabbix.com/${PN}/sources/stable/4.0/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
-KEYWORDS="~amd64 ~x86"
-IUSE="+agent java curl frontend ipv6 xmpp ldap libxml2 mysql openipmi oracle +postgres proxy server ssh ssl snmp sqlite odbc static"
+KEYWORDS="amd64 x86"
+IUSE="+agent curl frontend gnutls ipv6 java ldap libxml2 mbedtls mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static xmpp"
REQUIRED_USE="|| ( agent frontend proxy server )
- proxy? ( ^^ ( mysql oracle postgres sqlite odbc ) )
- server? ( ^^ ( mysql oracle postgres odbc ) )
+ ssl? ( ^^ ( gnutls mbedtls openssl ) )
+ proxy? ( ^^ ( mysql oracle postgres sqlite ) )
+ server? ( ^^ ( mysql oracle postgres ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -44,7 +45,11 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ mbedtls? ( net-libs/mbedtls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
xmpp? ( dev-libs/iksemel )
"
@@ -139,17 +144,19 @@ src_configure() {
$(use_enable server) \
$(use_enable static) \
$(use_with curl libcurl) \
+ $(use_with gnutls) \
$(use_with ldap) \
$(use_with libxml2) \
+ $(use_with mbedtls) \
$(use_with mysql) \
$(use_with odbc unixodbc) \
$(use_with openipmi openipmi) \
+ $(use_with openssl) \
$(use_with oracle) \
$(use_with postgres postgresql) \
$(use_with snmp net-snmp) \
$(use_with sqlite sqlite3) \
$(use_with ssh ssh2) \
- $(use_with ssl openssl) \
$(use_with xmpp jabber)
}