summaryrefslogtreecommitdiff
path: root/net-analyzer/yersinia/yersinia-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-analyzer/yersinia/yersinia-9999.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-analyzer/yersinia/yersinia-9999.ebuild')
-rw-r--r--net-analyzer/yersinia/yersinia-9999.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/yersinia/yersinia-9999.ebuild b/net-analyzer/yersinia/yersinia-9999.ebuild
new file mode 100644
index 000000000000..f2825d6f6f13
--- /dev/null
+++ b/net-analyzer/yersinia/yersinia-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic git-r3
+
+DESCRIPTION="A framework for layer 2 attacks"
+HOMEPAGE="https://github.com/tomac/yersinia"
+EGIT_REPO_URI="https://github.com/tomac/yersinia"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="gtk ncurses"
+
+RDEPEND="
+ ncurses? ( >=sys-libs/ncurses-5.5:= )
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ =x11-libs/gtk+-2*
+ )
+ >=net-libs/libnet-1.1.2
+ >=net-libs/libpcap-0.9.4
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+DOCS=( AUTHORS ChangeLog FAQ README THANKS TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.1-no-ncurses.patch
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use gtk; then
+ #bug #514802
+ sed -i -e '/AM_GLIB_GNU_GETTEXT/d' configure.in || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+
+ econf \
+ --enable-admin \
+ --with-pcap-includes=/usr/include \
+ $(use_with ncurses) \
+ $(use_enable gtk)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}