summaryrefslogtreecommitdiff
path: root/net-analyzer/xprobe/xprobe-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/xprobe/xprobe-0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/xprobe/xprobe-0.3.ebuild')
-rw-r--r--net-analyzer/xprobe/xprobe-0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/xprobe/xprobe-0.3.ebuild b/net-analyzer/xprobe/xprobe-0.3.ebuild
new file mode 100644
index 000000000000..fd60ee96cc6d
--- /dev/null
+++ b/net-analyzer/xprobe/xprobe-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
+HOMEPAGE="http://sys-security.com/blog/xprobe2"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -i -e 's:strip:true:' src/Makefile.in || die
+}
+
+src_install() {
+ default
+ dodoc AUTHORS CHANGELOG CREDITS README TODO docs/*.{txt,pdf}
+}