summaryrefslogtreecommitdiff
path: root/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /net-analyzer/xprobe/xprobe-0.3-r1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'net-analyzer/xprobe/xprobe-0.3-r1.ebuild')
-rw-r--r--net-analyzer/xprobe/xprobe-0.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/xprobe/xprobe-0.3-r1.ebuild b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
new file mode 100644
index 000000000000..209b65fecc78
--- /dev/null
+++ b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
+HOMEPAGE="http://sys-security.com/blog/xprobe2"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-cxx11.patch
+)
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ sed -i -e 's:strip:true:' src/Makefile.in || die
+ sed -i -e 's:ar cr:$(AR) cr:g' $(find -name '*Makefile*') || die
+
+ tc-export AR
+}
+
+src_install() {
+ default
+ dodoc AUTHORS CHANGELOG CREDITS README TODO docs/*.{txt,pdf}
+}