summaryrefslogtreecommitdiff
path: root/net-analyzer/wtfis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 07:07:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 07:07:57 +0000
commitbed152ba1fc2f1316eaefb5c3d24d48195560f76 (patch)
tree0564fbaf0c7ff23390031d68b741e89a40071333 /net-analyzer/wtfis
parent57c2e006d0af9ab77ced676461d7100cade4a716 (diff)
gentoo auto-resync : 23:11:2022 - 07:07:57
Diffstat (limited to 'net-analyzer/wtfis')
-rw-r--r--net-analyzer/wtfis/Manifest4
-rw-r--r--net-analyzer/wtfis/metadata.xml22
-rw-r--r--net-analyzer/wtfis/wtfis-0.4.0.ebuild38
-rw-r--r--net-analyzer/wtfis/wtfis-9999.ebuild38
4 files changed, 102 insertions, 0 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
new file mode 100644
index 000000000000..2d89135f714b
--- /dev/null
+++ b/net-analyzer/wtfis/Manifest
@@ -0,0 +1,4 @@
+DIST wtfis-0.4.0.gh.tar.gz 459363 BLAKE2B 10338f17700815aa8f25bd1e9587855795710925481ea3d7bd85782fea657055053d965977f601bc25d624352c97c639008d33d30aa3ac248ea7504c7e0ceaa7 SHA512 bb19923668e8172fd07b86159839c95a1b32d9975edcf1e9ab99bb574eae24f70c3a6bf83cc8ade66c1e5f57632625e7f604966ee06445839df87a9af4962573
+EBUILD wtfis-0.4.0.ebuild 964 BLAKE2B 66c5cbfee274186ae7a8f898bcbb7b1b1e3df9f956ef42cc82fe3c8e74dc0e7282b2a4a813dfcb4b42f2a0e6fd78a73fe77143f41f0dbaf847d642335d4c4866 SHA512 baa1c98f33251815252d6f972040bebcbec92f32867bfddf628a4b176c396068b5ad1e3161bb599100f12936315f5590b99d29ea3c395f9227e6edcc58e14432
+EBUILD wtfis-9999.ebuild 964 BLAKE2B 66c5cbfee274186ae7a8f898bcbb7b1b1e3df9f956ef42cc82fe3c8e74dc0e7282b2a4a813dfcb4b42f2a0e6fd78a73fe77143f41f0dbaf847d642335d4c4866 SHA512 baa1c98f33251815252d6f972040bebcbec92f32867bfddf628a4b176c396068b5ad1e3161bb599100f12936315f5590b99d29ea3c395f9227e6edcc58e14432
+MISC metadata.xml 855 BLAKE2B 552b9998e0eada39d9a0f0e092c566e9a75c5ac2e2360df66d9b7334e663a9fb4a82be51f31623f31644e2863d78570405dc94e36769be7cbbcc3539cf49d920 SHA512 56593e8b58a019e4cdbf23946331c34f66fc72e318271916b33f3f63ccfb2d7a546dcbf05fcd0bd0bce9e5e0ce8f7b0cfd621b4b938c0eed135c34d025fdfc32
diff --git a/net-analyzer/wtfis/metadata.xml b/net-analyzer/wtfis/metadata.xml
new file mode 100644
index 000000000000..495aa987e99e
--- /dev/null
+++ b/net-analyzer/wtfis/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ wtfis is a commandline tool that gathers information about a domain,
+ FQDN or IP address using various OSINT services. Unlike other tools of
+ its kind, it's built specifically for human consumption, providing
+ results that are pretty (YMMV) and easy to read and understand.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pirxthepilot/wtfis</remote-id>
+ <remote-id type="pypi">wtfis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/wtfis/wtfis-0.4.0.ebuild b/net-analyzer/wtfis/wtfis-0.4.0.ebuild
new file mode 100644
index 000000000000..f8b9786fcce5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/net-analyzer/wtfis/wtfis-9999.ebuild b/net-analyzer/wtfis/wtfis-9999.ebuild
new file mode 100644
index 000000000000..f8b9786fcce5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest