summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /net-analyzer/wireshark/wireshark-99999999.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'net-analyzer/wireshark/wireshark-99999999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index c964508b1b07..a4453c74df19 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit fcaps flag-o-matic git-r3 multilib python-r1 qmake-utils user xdg-utils cmake-utils
+inherit fcaps flag-o-matic git-r3 multilib python-any-r1 qmake-utils user xdg-utils cmake-utils
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -15,9 +15,9 @@ KEYWORDS=""
IUSE="
adns androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc
dpauxmon +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap
- +netlink nghttp2 +plugins plugin_ifdemo +pcap +qt5 +randpkt +randpktdump
- +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
- +text2pcap tfshark +tshark +udpdump zlib
+ +minizip +netlink nghttp2 +plugins plugin_ifdemo +pcap +qt5 +randpkt
+ +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl
+ sdjournal +text2pcap tfshark +tshark +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -34,6 +34,7 @@ CDEPEND="
lua? ( >=dev-lang/lua-5.1:* )
lz4? ( app-arch/lz4 )
maxminddb? ( dev-libs/libmaxminddb )
+ minizip? ( sys-libs/zlib[minizip] )
netlink? ( dev-libs/libnl:3 )
nghttp2? ( net-libs/nghttp2 )
pcap? ( net-libs/libpcap )
@@ -81,7 +82,6 @@ RDEPEND="
selinux? ( sec-policy/selinux-wireshark )
"
REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
plugin_ifdemo? ( plugins )
"
PATCHES=(
@@ -118,7 +118,7 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
- python_setup 'python3*'
+ python_setup
mycmakeargs+=(
$(use androiddump && use pcap && echo -DEXTCAP_ANDROIDDUMP_LIBPCAP=yes)
@@ -158,6 +158,7 @@ src_configure() {
-DENABLE_LIBXML2=$(usex libxml2)
-DENABLE_LUA=$(usex lua)
-DENABLE_LZ4=$(usex lz4)
+ -DENABLE_MINIZIP=$(usex minizip)
-DENABLE_NETLINK=$(usex netlink)
-DENABLE_NGHTTP2=$(usex nghttp2)
-DENABLE_PCAP=$(usex pcap)