summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-analyzer/wireshark/wireshark-99999999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-analyzer/wireshark/wireshark-99999999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 580fa7c54d0b..bb74c3376075 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -3,11 +3,11 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit fcaps flag-o-matic git-r3 multilib python-any-r1 qmake-utils user xdg-utils cmake
+inherit fcaps flag-o-matic git-r3 multilib python-any-r1 qmake-utils xdg-utils cmake
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
-EGIT_REPO_URI="https://code.wireshark.org/review/wireshark"
+EGIT_REPO_URI="https://gitlab.com/wireshark/wireshark"
LICENSE="GPL-2"
SLOT="0/${PV}"
@@ -19,9 +19,11 @@ IUSE="
+randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl
sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd
"
+RESTRICT="!test? ( test )"
S=${WORKDIR}/${P/_/}
CDEPEND="
+ acct-group/pcap
>=dev-libs/glib-2.32:2
>=net-dns/c-ares-1.5
dev-libs/libgcrypt:0
@@ -93,10 +95,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-99999999-ui-needs-wiretap.patch
)
-pkg_setup() {
- enewgroup wireshark
-}
-
src_configure() {
local mycmakeargs
@@ -147,7 +145,6 @@ src_configure() {
-DBUILD_tshark=$(usex tshark)
-DBUILD_udpdump=$(usex udpdump)
-DBUILD_wireshark=$(usex qt5)
- -DCMAKE_INSTALL_DOCDIR="${EROOT}/usr/share/doc/${PF}"
-DDISABLE_WERROR=yes
-DENABLE_BCG729=$(usex bcg729)
-DENABLE_BROTLI=$(usex brotli)
@@ -238,17 +235,16 @@ pkg_postinst() {
xdg_mimeinfo_database_update
# Add group for users allowed to sniff.
- enewgroup wireshark
- chgrp wireshark "${EROOT}"/usr/bin/dumpcap
+ chgrp pcap "${EROOT}"/usr/bin/dumpcap
if use dumpcap && use pcap; then
- fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ fcaps -o 0 -g pcap -m 4710 -M 0710 \
cap_dac_read_search,cap_net_raw,cap_net_admin \
"${EROOT}"/usr/bin/dumpcap
fi
ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
- ewarn "add yourself to the wireshark group. This security measure ensures"
+ ewarn "add yourself to the pcap group. This security measure ensures"
ewarn "that only trusted users are allowed to sniff your traffic."
}