summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /net-analyzer/wireshark/wireshark-99999999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'net-analyzer/wireshark/wireshark-99999999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 42ebd544329b..937819a5e035 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6,7} )
-inherit cmake-utils fcaps flag-o-matic git-r3 ltprune multilib python-r1 qmake-utils user xdg-utils
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit fcaps flag-o-matic git-r3 multilib python-r1 qmake-utils user xdg-utils cmake-utils
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -13,11 +13,11 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="
- adns androiddump bcg729 +capinfos +captype ciscodump +dftest doc dpauxmon
- +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap +netlink
- nghttp2 +pcap +qt5 +randpkt +randpktdump +reordercap sbc selinux +sharkd
- smi snappy spandsp sshdump ssl sdjournal +text2pcap tfshark +tshark
- +udpdump zlib
+ adns androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc
+ dpauxmon +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap
+ +netlink nghttp2 +plugins plugin_ifdemo +pcap +qt5 +randpkt +randpktdump
+ +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
+ +text2pcap tfshark +tshark +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -27,6 +27,7 @@ CDEPEND="
dev-libs/libgcrypt:0
adns? ( >=net-dns/c-ares-1.5 )
bcg729? ( media-libs/bcg729 )
+ brotli? ( app-arch/brotli )
ciscodump? ( >=net-libs/libssh-0.6 )
filecaps? ( sys-libs/libcap )
kerberos? ( virtual/krb5 )
@@ -59,6 +60,8 @@ CDEPEND="
DEPEND="
${CDEPEND}
${PYTHON_DEPS}
+"
+BDEPEND="
!<perl-core/Pod-Simple-3.170
!<virtual/perl-Pod-Simple-3.170
dev-lang/perl
@@ -80,6 +83,7 @@ RDEPEND="
"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
+ plugin_ifdemo? ( plugins )
"
PATCHES=(
"${FILESDIR}"/${PN}-2.4-androiddump.patch
@@ -147,6 +151,7 @@ src_configure() {
-DCMAKE_INSTALL_DOCDIR="/usr/share/doc/${PF}"
-DDISABLE_WERROR=yes
-DENABLE_BCG729=$(usex bcg729)
+ -DENABLE_BROTLI=$(usex brotli)
-DENABLE_CAP=$(usex filecaps caps)
-DENABLE_CARES=$(usex adns)
-DENABLE_GNUTLS=$(usex ssl)
@@ -157,6 +162,8 @@ src_configure() {
-DENABLE_NETLINK=$(usex netlink)
-DENABLE_NGHTTP2=$(usex nghttp2)
-DENABLE_PCAP=$(usex pcap)
+ -DENABLE_PLUGINS=$(usex plugins)
+ -DENABLE_PLUGIN_IFDEMO=$(usex plugin_ifdemo)
-DENABLE_SBC=$(usex sbc)
-DENABLE_SMI=$(usex smi)
-DENABLE_SNAPPY=$(usex snappy)
@@ -168,8 +175,7 @@ src_configure() {
}
src_test() {
- emake -C "${BUILD_DIR}" test-programs
- emake -C "${BUILD_DIR}" test
+ cmake-utils_src_test
}
src_install() {
@@ -215,8 +221,6 @@ src_install() {
newins image/WiresharkDoc-${s}.png application-vnd.tcpdump.pcap.png
done
fi
-
- prune_libtool_files
}
pkg_postinst() {