summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 01:09:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 01:09:33 +0000
commit58523314abd7b5740c06e3bbcd41ada404e7c612 (patch)
tree2ec4372c4b63bd8679af9b4c591c2743e421b1b9 /net-analyzer/wireshark/wireshark-9999.ebuild
parent4fc30e4e13ecfbe29fbef3b5caf96218eab30b68 (diff)
gentoo auto-resync : 13:01:2024 - 01:09:33
Diffstat (limited to 'net-analyzer/wireshark/wireshark-9999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 5409368db461..17400f26949a 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -32,7 +32,7 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc dpauxmon"
-IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lto lua lz4 maxminddb"
+IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lua lz4 maxminddb"
IUSE+=" +mergecap +minizip +netlink opus +plugins +pcap qt6 +randpkt"
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump wifi zlib +zstd"
@@ -194,7 +194,9 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
- ! use lto && filter-lto
+ # crashes at runtime
+ # https://bugs.gentoo.org/754021
+ filter-lto
mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
@@ -238,7 +240,8 @@ src_configure() {
-DENABLE_ILBC=$(usex ilbc)
-DENABLE_KERBEROS=$(usex kerberos)
-DENABLE_LIBXML2=$(usex libxml2)
- -DENABLE_LTO=$(usex lto)
+ # only appends -flto
+ -DENABLE_LTO=OFF
-DENABLE_LUA=$(usex lua)
-DLUA_FIND_VERSIONS="${ELUA#lua}"
-DENABLE_LZ4=$(usex lz4)