summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-analyzer/wireshark/wireshark-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-analyzer/wireshark/wireshark-9999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 3c9c26865ea3..68dc99e8c15c 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -86,8 +86,10 @@ BDEPEND="${PYTHON_DEPS}
dev-qt/linguist-tools:5
)
test? (
- dev-python/pytest
- dev-python/pytest-xdist
+ $(python_gen_any_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
)"
RDEPEND="${RDEPEND}
qt5? ( virtual/freedesktop-icon-theme )
@@ -98,8 +100,17 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.4.2-cmake-lua-version.patch
)
+python_check_deps() {
+ use test || return 0
+
+ python_has_version -b "dev-python/pytest[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/pytest-xdist[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
use lua && lua-single_pkg_setup
+
+ python-any-r1_pkg_setup
}
src_configure() {
@@ -153,7 +164,7 @@ src_configure() {
-DBUILD_tshark=$(usex tshark)
-DBUILD_udpdump=$(usex udpdump)
-DBUILD_wireshark=$(usex qt5)
- -DDISABLE_WERROR=yes
+ -DDISABLE_WERROR=ON
-DENABLE_BCG729=$(usex bcg729)
-DENABLE_BROTLI=$(usex brotli)
-DENABLE_CAP=$(usex filecaps caps)
@@ -185,18 +196,11 @@ src_configure() {
src_test() {
cmake_build test-programs
- myctestargs=(
- --disable-capture
- --skip-missing-programs=all
- --verbose
-
- # Skip known failing tests
- # extcaps needs a bunch of external programs
- -E "(suite_extcaps)"
- #-E "(suite_decryption|suite_extcaps|suite_nameres)"
- )
-
- cmake_src_test
+ # https://www.wireshark.org/docs/wsdg_html_chunked/ChTestsRunPytest.html
+ epytest \
+ --disable-capture \
+ --skip-missing-programs=all \
+ --program-path "${BUILD_DIR}"/run
}
src_install() {