summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti/wapiti-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-analyzer/wapiti/wapiti-9999.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-analyzer/wapiti/wapiti-9999.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
index 8a61f85b7acf..ef1480dd21ea 100644
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ b/net-analyzer/wapiti/wapiti-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE='xml'
inherit distutils-r1 git-r3
@@ -15,13 +15,8 @@ EGIT_REPO_URI="https://git.code.sf.net/p/wapiti/git wapiti-git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="kerberos ntlm test"
+IUSE="kerberos ntlm"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
@@ -31,6 +26,9 @@ RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+distutils_enable_tests pytest
+BDEPEND+=" test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+
python_prepare_all() {
sed -e 's/"pytest-runner"//' -i setup.py || die
distutils-r1_python_prepare_all