summaryrefslogtreecommitdiff
path: root/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/ttcp/ttcp-1.12-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/ttcp/ttcp-1.12-r2.ebuild')
-rw-r--r--net-analyzer/ttcp/ttcp-1.12-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/ttcp/ttcp-1.12-r2.ebuild b/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
new file mode 100644
index 000000000000..14f85101f144
--- /dev/null
+++ b/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to test TCP and UDP throughput"
+HOMEPAGE="
+ http://ftp.arl.mil/~mike/ttcp.html
+ http://www.netcore.fi/pekkas/linux/ipv6/
+"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ http://www.netcore.fi/pekkas/linux/ipv6/${PN}.c
+"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+ newman sgi-${PN}.1 ${PN}.1
+}