summaryrefslogtreecommitdiff
path: root/net-analyzer/traceroute/traceroute-2.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 10:10:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 10:10:44 +0100
commit0fde6d7108b1ee9fc6ad186eff4978faa255db20 (patch)
tree54c45a4fb87434f176ae2cc91c764acdcc1122e7 /net-analyzer/traceroute/traceroute-2.1.3.ebuild
parent025c71a90f259ca9319b4caa92495e43acf489b0 (diff)
gentoo auto-resync : 31:08:2023 - 10:10:44
Diffstat (limited to 'net-analyzer/traceroute/traceroute-2.1.3.ebuild')
-rw-r--r--net-analyzer/traceroute/traceroute-2.1.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/traceroute/traceroute-2.1.3.ebuild b/net-analyzer/traceroute/traceroute-2.1.3.ebuild
new file mode 100644
index 000000000000..4905daf3cb3a
--- /dev/null
+++ b/net-analyzer/traceroute/traceroute-2.1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Utility to trace the route of IP packets"
+HOMEPAGE="https://traceroute.sourceforge.net/"
+SRC_URI="mirror://sourceforge/traceroute/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static"
+
+RDEPEND="!net-misc/iputils[traceroute6(-)]"
+
+src_compile() {
+ use static && append-ldflags -static
+ # bug #432116
+ append-ldflags -L../libsupp
+ tc-export AR CC RANLIB
+
+ emake env=yes
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ dodoc ChangeLog CREDITS README TODO
+ dosym traceroute /usr/bin/traceroute6
+ dosym traceroute.8 /usr/share/man/man8/traceroute6.8
+}