summaryrefslogtreecommitdiff
path: root/net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2_p1.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2_p1.ebuild')
-rw-r--r--net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2_p1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2_p1.ebuild b/net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2_p1.ebuild
new file mode 100644
index 000000000000..975f26afff90
--- /dev/null
+++ b/net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2_p1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DEB_PL="1"
+DESCRIPTION="Traceroute with AS lookup, TOS support, MTU discovery and other features"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="
+ https://dev.gentoo.org/~jer/${PN}_${PV/_p*}.orig.tar.gz
+ https://dev.gentoo.org/~jer/${PN}_${PV/_p*}-${PV/*_p}.diff.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+S=${WORKDIR}/${P/_p*}.orig
+
+src_prepare() {
+ eapply "${WORKDIR}"/${PN}_${PV/_p*}-${PV/*_p}.diff
+
+ eapply \
+ $(
+ for i in $( cat "${S}"/debian/patches/00list )
+ do
+ echo "${S}"/debian/patches/$i.dpatch
+ done
+ )
+
+ eapply_user
+}
+
+src_compile() {
+ $(tc-getCC) traceroute.c -o ${PN} ${CFLAGS} -DSTRING ${LDFLAGS} -lresolv -lm \
+ || die
+}
+
+src_install() {
+ dosbin traceroute-nanog
+ dodoc 0_readme.txt faq.txt
+ newman "${S}"/debian/traceroute-nanog.genuine.8 traceroute-nanog.8
+}