summaryrefslogtreecommitdiff
path: root/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild')
-rw-r--r--net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
index 15e52604060b..28f0ddbe591e 100644
--- a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
+++ b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools
+EAPI=7
+
+inherit autotools
MY_PV=${PV/_/}
@@ -18,11 +19,11 @@ IUSE="debug"
RDEPEND="
net-libs/libnet:1.1
net-libs/libpcap
- sys-libs/ncurses
+ sys-libs/ncurses:0=
debug? ( dev-libs/dmalloc )
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
app-doc/doxygen[dot]
virtual/pkgconfig
"
@@ -31,8 +32,13 @@ S=${WORKDIR}/${PN}-${MY_PV}
DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}/${P}-tinfo.patch"
+ "${FILESDIR}/${P}-fno-common.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-tinfo.patch
+ default
eautoreconf
}