summaryrefslogtreecommitdiff
path: root/net-analyzer/thc-ipv6/thc-ipv6-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/thc-ipv6/thc-ipv6-2.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/thc-ipv6/thc-ipv6-2.5.ebuild')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-2.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-2.5.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-2.5.ebuild
new file mode 100644
index 000000000000..4b3cd8777b52
--- /dev/null
+++ b/net-analyzer/thc-ipv6/thc-ipv6-2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+HOMEPAGE="http://freeworld.thc.org/thc-ipv6/"
+SRC_URI="http://freeworld.thc.org/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3 openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="net-libs/libpcap
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1-Makefile.patch
+ if ! use ssl ; then
+ sed -e '/^HAVE_SSL/s:^:#:' \
+ -i Makefile
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
+ dodoc CHANGES HOWTO-INJECT README
+}