summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild')
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild33
1 files changed, 17 insertions, 16 deletions
diff --git a/net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild b/net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild
index e988b2260bdb..eca9e30b0bd3 100644
--- a/net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild
+++ b/net-analyzer/tcpslice/tcpslice-1.2a_p3_p4.ebuild
@@ -1,36 +1,37 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools flag-o-matic
+
+inherit autotools
MY_P="${PN}_$(ver_cut 1).$(ver_cut 2-3)$(ver_cut 5)"
DESCRIPTION="Extract and concatenate portions of pcap files"
HOMEPAGE="http://www.tcpdump.org/ https://github.com/the-tcpdump-group/tcpslice"
-LICENSE="BSD"
-SLOT="0"
SRC_URI="
mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.orig.tar.gz
mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}-$(ver_cut 7).debian.tar.gz
"
+S="${WORKDIR}"/${MY_P/_/-}
+
+LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-RDEPEND="
- net-libs/libpcap
-"
-DEPEND="
- ${RDEPEND}
-"
-S=${WORKDIR}/${MY_P/_/-}
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
src_prepare() {
- eapply \
- "${WORKDIR}"/debian/patches/[0-]* \
- "${FILESDIR}"/${PN}-1.2a_p3-exit.patch
- eapply_user
+ eapply "${WORKDIR}"/debian/patches/[0-]*
+ eapply "${FILESDIR}"/${PN}-1.2a_p3-exit.patch
+
+ default
+
sed -i -e 's|ifndef lint|if 0|g' *.c || die
- eautoconf
+
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {