summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-analyzer/tcpreplay
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/Manifest2
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.3.3_beta1.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index 6eca5dd6b2e7..7b042b914237 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,5 +1,7 @@
AUX tcpreplay-4.3.0-enable-pcap_findalldevs.patch 333 BLAKE2B 1beb39a7263bf8491998760e4a62ac8908300e28c43500812d37d2512f9d63fcd175b93c1b384e03e9570e741dd95dea09ead017a014a4b62b3449833fe9b248 SHA512 3d035736c0656f6ace85b45af595866e06c8464641023e9d1606c288e598cde18eb96b1be8300514f6f31bc83756ae76b436402666036456571201ca38fe5026
DIST tcpreplay-4.3.2.tar.xz 747268 BLAKE2B 27cad902785975f9c7fbfb8abef24ae95fbc8812e0a4fabd3b1ecf74bb9f0a99cdb0c37db72c433296d3cebba89d0bbc90e944195e585bf2d1c2d93ef234c4f6 SHA512 641dd636d9c5c30637d0103f8b21da3ce234f9e3ed7ab4d2b20d004fc4a14301672dcd678b2d5e0eb90d55a97bcb0c4c67f31c790a5aa3c509a92d1142c5b7b9
+DIST tcpreplay-4.3.3_beta1.tar.xz 748424 BLAKE2B 9bccca73c0be4d6a72a61f2ebd4c6f61c160d829772605183e25177d4356e01d83be0602eaa84d154df2c316db1c6d09899e49311137be734a4c0b373be6e77f SHA512 d8c80d107ca0fdddc5d2ef88924cdee8b5897e0f4bb468b982f4bbacb01547a40c4fa324f7ee7dd93e1288c87e11e709a99c08e31d397b8ca3f28cc78e6d61a4
EBUILD tcpreplay-4.3.2.ebuild 1870 BLAKE2B b3259f3304d9a352c41843ad22808a10e0060437fe2476398a5ed5d0b2d6ebfe53375e73829ab831dbaa8fcb83dcce5008a2d994888e4db65c95cf3ab9db6cad SHA512 4aa9cc30b785932ed73c19e001f36c73f6191af1cb739637dbe6cd5b541811f3818ce4c64e14e8910a1d505708f6467ca1e2874a0cd54b7eb174d6f31ac62d4f
+EBUILD tcpreplay-4.3.3_beta1.ebuild 1872 BLAKE2B 5fcfd4a57e6023865d261d022e6ac79f72cb0b2b773cd95b99202099767e8a6ed1288a5a38efffaed373da8f258d21f9b17ca88424dbf35064b4f28228804156 SHA512 3e385b4425ad1e832b810ebc77bbb15eaa4d09f57661275c0b724b5c9477bf2bb1cb1117592751344c7ffc7ec5666b6a49f2fd7a2eb9efad9901acd61524576c
EBUILD tcpreplay-999999.ebuild 1809 BLAKE2B 196a27e64b132ffa5440aa7b540c4939d62dda5191ddc169a85b198f87d84cfcb15f26404e1c335ead442efa8a0cd70f795bceb3fa25736d525accaa42b448dd SHA512 2690427a1bcec51a564bf8dd6bac157a5bfa2dd27fe9c884c37b89b23963fe791a720c703cc4421d9955e8697f2209152e041302aeb767b40dfb052e7b0cfffd
MISC metadata.xml 1116 BLAKE2B 23c8b7009a77b68831affc57432a87a31fde213d7e7ee88f68ced4a4e21a56c55f97497e610fc486a42c699759ef1edf1904fa9b0fe976df4fc9930535f97037 SHA512 58cb13a648ba7b9f9fd8c7a7cdfd37d56f0d7b957824a55d63001a8708f93d529b29e52df051bdce0c87eb672d24c7b2c35ee8a1e94ba062e2a1e12dd0d0ee1b
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.3_beta1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.3_beta1.ebuild
new file mode 100644
index 000000000000..015df52f86f9
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.3.3_beta1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+LICENSE="BSD GPL-3"
+SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="debug pcapnav +tcpdump"
+
+DEPEND="
+ >=sys-devel/autogen-5.18.4[libopts]
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ tcpdump? ( net-analyzer/tcpdump )
+ pcapnav? ( net-libs/libpcapnav )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ docs/{CHANGELOG,CREDIT,HACKING,TODO}
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+)
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug 252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ --enable-dynamic-link \
+ --enable-local-libopts \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]]; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up." ;
+ die "self test failed - see ${S}/test/test.log" ; }
+ fi
+}