summaryrefslogtreecommitdiff
path: root/net-analyzer/tcping/tcping-1.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-analyzer/tcping/tcping-1.3.6.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-analyzer/tcping/tcping-1.3.6.ebuild')
-rw-r--r--net-analyzer/tcping/tcping-1.3.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/tcping/tcping-1.3.6.ebuild b/net-analyzer/tcping/tcping-1.3.6.ebuild
new file mode 100644
index 000000000000..ac21b008725e
--- /dev/null
+++ b/net-analyzer/tcping/tcping-1.3.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Check if a desired port is reachable via TCP"
+HOMEPAGE="https://github.com/mkirchner/tcping"
+SRC_URI="https://github.com/mkirchner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -e '/^CC=/s:=:?=:' \
+ -e '/^CCFLAGS/s:=:+=:' \
+ -e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
+ -i Makefile || die
+ tc-export CC
+ export CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcping
+ dodoc README
+}