summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch')
-rw-r--r--net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch b/net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch
new file mode 100644
index 000000000000..de0864004a0c
--- /dev/null
+++ b/net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch
@@ -0,0 +1,61 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,6 @@
+ AC_PROG_INSTALL
+
+ m4_include([m4/slg_searchdirs.m4])
+-m4_include([m4/slg_gcc_all_warnings.m4])
+
+
+ # use C++11 mode if available; HAVE_CXX11 is defined in config.h if so. Don't
+@@ -402,7 +402,12 @@
+ AC_CHECK_HEADERS(cap-ng.h)
+ fi
+
+-
++################################################################
++# http-parser
++
++AC_CHECK_LIB(http_parser,http_parser_init,,
++ AC_MSG_ERROR([http-parser library not installed]))
++AC_CHECK_HEADERS(http_parser.h)
+
+ ################################################################
+ # Specify our other headers
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -90,20 +90,12 @@
+ scan_netviz.cpp \
+ pcap_writer.h \
+ iptree.h \
+- http-parser/http_parser.c \
+- http-parser/http_parser.h \
+ mime_map.cpp \
+ mime_map.h
+
+ EXTRA_DIST =\
+ inet_ntop.c \
+ inet_ntop.h \
+- http-parser/AUTHORS \
+- http-parser/CONTRIBUTIONS \
+- http-parser/LICENSE-MIT \
+- http-parser/Makefile \
+- http-parser/README.md \
+- http-parser/http_parser.gyp \
+ wifipcap/README.txt \
+ wifipcap/TimeVal.cpp \
+ wifipcap/TimeVal.h \
+--- a/src/scan_http.cpp
++++ b/src/scan_http.cpp
+@@ -11,7 +11,11 @@
+ #include "tcpip.h"
+ #include "tcpdemux.h"
+
++#ifdef HAVE_HTTP_PARSER_H
++#include "http_parser.h"
++#else
+ #include "http-parser/http_parser.h"
++#endif
+
+ #include "mime_map.h"
+