summaryrefslogtreecommitdiff
path: root/net-analyzer/snortalog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-analyzer/snortalog
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-analyzer/snortalog')
-rw-r--r--net-analyzer/snortalog/Manifest2
-rw-r--r--net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild24
2 files changed, 17 insertions, 9 deletions
diff --git a/net-analyzer/snortalog/Manifest b/net-analyzer/snortalog/Manifest
index 6cd13ebb9dd9..4654f8244c85 100644
--- a/net-analyzer/snortalog/Manifest
+++ b/net-analyzer/snortalog/Manifest
@@ -1,3 +1,3 @@
DIST snortalog_v2.4.3.tar 1324032 BLAKE2B dae81fe861c7d85ce5fce63ffe773cccb8b643654a861e1b9cc91db22e5683c4a5d2c83ee6a1895386777c600b004978f91e3ed8a333397139bfe6f9644a79ce SHA512 b4b8558865ae4d1ef932114f2a2fb5af7fb069f1b587955d9d489a31635e890fb0ed36ebcde19322ab0c0cae49734da08602e283bd731c769de527abf7d74d06
-EBUILD snortalog-2.4.3-r1.ebuild 1439 BLAKE2B d8bc3709fec9b09e1273b1b638a922a7ea63fb7a6bf373a457151301d4c0a827fb8cea4c5b7c0075715d1158280127e30c8ce5b236738a78715bc069b4f1783a SHA512 57b4291d92d321e72c57941a2a9d74b104afd8662d0f679ebb44ab428b2c96fb01785cf8218d84739bef90ed7b88a4ad92c504abcf024303789128068a5d37fa
+EBUILD snortalog-2.4.3-r1.ebuild 1552 BLAKE2B 464b9276a173de2be490da6dfd6a039c6a13bd250e4306977b84983ed8126eb7eceb8cc72288c5ebce439ba94013e2287e7d56e6b9d69ab9e7baf08394729b30 SHA512 a1ef4a92bdf7806ef534ffc6cbe0e7500c313d13819f04ed28ccfb78792bb8c7f353c86af237e41f46003c7d3ee59591ff7c573fe8022726b04e6f33b43dcb1e
MISC metadata.xml 276 BLAKE2B e21811549278e73aa9a14acfe242fd022106a39ac1300caa00615772d7f54d08a433052659a271f9ac0d453c7776fc2b9e8d86e6d3f637817c214174dde52cb2 SHA512 f0e6c6bc89659e01e157d9bf30d0a2f3fd2d71bc26c8d12489c4a44fc5237159946e25b46e7295ab4676aea63559194977a0b1e76aced31d81cf6387dd0f4250
diff --git a/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild b/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
index 18e2cd14b905..960612b2f88f 100644
--- a/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
+++ b/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils
+EAPI=7
MY_P="${PN}_v${PV}"
-DESCRIPTION="a powerful perl script that summarizes snort logs"
+inherit edos2unix
+
+DESCRIPTION="A powerful perl script that summarizes snort logs"
HOMEPAGE="http://jeremy.chartier.free.fr/snortalog/"
SRC_URI="http://jeremy.chartier.free.fr/snortalog/downloads/${PN}/${MY_P}.tar"
+S="${WORKDIR}"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
IUSE="tk"
@@ -24,10 +26,16 @@ RDEPEND="
tk? ( dev-perl/Tk )
"
-S=${WORKDIR}
-
src_prepare() {
- edos2unix $(find conf/ modules/ -type f) ${PN}.* CHANGES
+ default
+
+ local convert=$(find conf/ modules/ -type f || die)
+ convert+=( ${PN}.* CHANGES )
+
+ local item
+ for item in ${convert[@]} ; do
+ edos2unix "${item}"
+ done
# fix paths, erroneous can access message
sed -i \