summaryrefslogtreecommitdiff
path: root/net-analyzer/siphon/siphon-666-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /net-analyzer/siphon/siphon-666-r2.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'net-analyzer/siphon/siphon-666-r2.ebuild')
-rw-r--r--net-analyzer/siphon/siphon-666-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/siphon/siphon-666-r2.ebuild b/net-analyzer/siphon/siphon-666-r2.ebuild
new file mode 100644
index 000000000000..7921c66b9a14
--- /dev/null
+++ b/net-analyzer/siphon/siphon-666-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=${PN}-v.${PV}
+
+DESCRIPTION="A portable passive network mapping suite"
+HOMEPAGE="http://siphon.datanerds.net/"
+SRC_URI="http://siphon.datanerds.net/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-log.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc
+ doins osprints.conf
+ dodoc README
+}