summaryrefslogtreecommitdiff
path: root/net-analyzer/rrdtool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
commitbe8708090362c01c6111c4b76f1e395c14d86e00 (patch)
treebb61ca73e867522450783849eb63c9e1f0ba1730 /net-analyzer/rrdtool
parente93a38d535f2c29b55a5756d2de99425986b0bf3 (diff)
gentoo auto-resync : 13:08:2024 - 11:06:03
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/Manifest2
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.9.0.ebuild253
2 files changed, 255 insertions, 0 deletions
diff --git a/net-analyzer/rrdtool/Manifest b/net-analyzer/rrdtool/Manifest
index 33de2736cb29..60ea1c8abdd2 100644
--- a/net-analyzer/rrdtool/Manifest
+++ b/net-analyzer/rrdtool/Manifest
@@ -5,5 +5,7 @@ AUX rrdtool-1.7.1-configure.ac.patch 257 BLAKE2B 9aa11b7b0392cb2427d686b888c29b0
AUX rrdtool-1.8.0-configure-clang16.patch 1435 BLAKE2B 15d1788f77b7aa5a52a7306ffacf865afa01fc58fdcb8e836980fb00a688d83b93398f3d1b1385f3f30b42adf8378fc222dad6c44712bfb2695ae7949ecb704d SHA512 8a60fdf7843ef294a933bfb268e976ad0bab09a9c7c9101b608998f968b2d2e9f081256498526e11bcc8c28bdcb446179c4ec8dc6790c83ca27f946e20ba5fa1
DIST rrdtool-1.8.0-gcc14.patch.gz 10775 BLAKE2B 9b8eeb829acec097bf06e3cad2fb4ca37a5d351fb3eca5767066d8cfb70c176c9d3b9265a721958b97e02f1c267b8b3a4b61ad35b0ca06199cc45c8c92f7dc09 SHA512 576be3d94a56edbc8738a32b934d30d8e45eb3e801854f73a3a77f5bd22bdd4618f68ea079f37992f38a9b756cac96e6cb48eeb5cceb4ff30139a2d77c9b0afe
DIST rrdtool-1.8.0.tar.gz 2955398 BLAKE2B d821d662af432c53760bc0e9636b84d9209933a810fa71091fc4c2b44518c89c7ad509bde7955d952279ee41464c3bfa4f631662dde61b6fff46699bb382653f SHA512 8ae6f94d119e8d0e1ba7f2d0738f1ba008a4880d1022f1c0c5436f662d961fceec5c42e01c241493ece3d6f55c60fd7d1d264f93e678f3cf1251201dcde027c1
+DIST rrdtool-1.9.0.tar.gz 2972593 BLAKE2B a5633b1bcacf53823f95f7899872e67d9941faec235c56546de8b66faf15a958a7c0d6a86d569c078e11a478dc272b1fbe784c3d3d9d45e8c3de696f0d6e378a SHA512 ebeb1fd9e1eed8e01d4d08a4f07aa22c272cc95ac87852f81a892690e6f446b5398bf64689ea99622779cba490722d97b325bda2d2a6d4dfc0719929b2a4c041
EBUILD rrdtool-1.8.0-r4.ebuild 5775 BLAKE2B aec297dd0fd7dd87caa1ceeb2a4a771d8c751fdc18bebac6440beeb96a4702369e1620472633a0746827a6bfb5e9ced42fc1352d0dffe6184095027787c01920 SHA512 98dbacde469b7a4ff087241ab06784edd4f2250dccb94f11771e906f87b50f9fd41b8ce33113494748451a079c983e377f32504dd694cd47be664b83cd3ab4f7
+EBUILD rrdtool-1.9.0.ebuild 5614 BLAKE2B 7c4c3dc04a3f1b029747c4a6f74aa340b1fa74f82d5b7e1d8192391baf88449b62b73b3b52e6899597f4f1ec6bf31746ea47c6d1cec6b82203ee493ef798d51b SHA512 b335810745aaed03ac19b930dc5f4fa2fa8a0416bc85f0e834b7626b300eb147ef6b49dd513ac23a4f641251bb15005595fa5ae8b90b41033833c1228df5d95e
MISC metadata.xml 767 BLAKE2B 12dd8f6fc7192dd214acb9b7ab3cb2bdfdd601ad768587ca0133ea132a2ffbc4aace5c7943c933b0b8e13d200ff5129882f9b47931421db9db2c017a398870ff SHA512 afca7f1c6ff9209ee1fe4977f5e9a063e37e3ee00a5a3ecd560e71fdf86df7daed526742bcd592d145df4b26ac206672135845fe67f8d2a64d5ae536113aa22f
diff --git a/net-analyzer/rrdtool/rrdtool-1.9.0.ebuild b/net-analyzer/rrdtool/rrdtool-1.9.0.ebuild
new file mode 100644
index 000000000000..bb6d0e943413
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.9.0.ebuild
@@ -0,0 +1,253 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+PYTHON_COMPAT=( python3_{9..13} )
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL="true"
+DISTUTILS_SINGLE_IMPL="true"
+DISTUTILS_USE_PEP517="setuptools"
+GENTOO_DEPEND_ON_PERL="no"
+MY_P="${P/_/-}"
+
+inherit autotools lua perl-module distutils-r1 flag-o-matic
+
+DESCRIPTION="A data logging and graphing system for time series data"
+HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
+SRC_URI="
+ https://github.com/oetiker/${PN}-1.x/releases/download/v${PV}/${P}.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0/8.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbi doc examples graph lua perl python rados rrdcached rrdcgi ruby static-libs tcl tcpd test"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ lua? (
+ ${LUA_REQUIRED_USE}
+ test? ( graph )
+ )
+ test? ( graph rrdcached )
+"
+
+PDEPEND="ruby? ( ~dev-ruby/rrdtool-bindings-${PV} )"
+
+RDEPEND="
+ dev-libs/glib:2[static-libs(+)?]
+ dev-libs/libxml2:2[static-libs(+)?]
+ dbi? ( dev-db/libdbi[static-libs(+)?] )
+ graph? (
+ media-libs/libpng:0=[static-libs(+)?]
+ x11-libs/cairo[svg(+),static-libs(+)?]
+ x11-libs/pango
+ )
+ lua? ( ${LUA_DEPS} )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ rados? ( sys-cluster/ceph )
+ rrdcached? (
+ acct-group/rrdcached
+ acct-user/rrdcached
+ )
+ tcl? ( dev-lang/tcl:0= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ ${DISTUTILS_DEPS}
+ sys-apps/groff
+ virtual/pkgconfig
+ app-alternatives/awk
+ python? ( $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]') )
+ test? (
+ app-alternatives/bc
+ lua? ( ${LUA_DEPS} )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0-disable-rrd_graph-cgi.patch
+ "${FILESDIR}"/${PN}-1.7.1-configure.ac.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Bug #456810
+ local mysedargs=(
+ -e 's|$LUA_CFLAGS|IGNORE_THIS_BAD_TEST|g'
+ -e 's|^sleep 1$||g'
+ -e '/^dnl.*png/s|^dnl||g'
+ -i configure.ac
+ )
+
+ sed "${mysedargs[@]}" || die
+
+ # Python bindings are built and installed manually
+ local mysedargs=(
+ -e '/^all-local:/s| @COMP_PYTHON@||'
+ -i bindings/Makefile.am
+ )
+
+ sed "${mysedargs[@]}" || die
+
+ # Makefile needs to be adjusted for disabling 'graph' feature
+ if ! use graph ; then
+ local mysedargs=(
+ -e '2s:rpn1::; 2s:rpn2::; 6s:create-with-source-4::;'
+ -e '7s:xport1::; 7s:dcounter1::; 7s:vformatter1::'
+ -e 's|graph1||g'
+ -i tests/Makefile.am
+ )
+
+ sed "${mysedargs[@]}" || die
+ fi
+
+ # Temporarily disable rpn test, will be enabled with > 1.8.0 release.
+ sed -e 's/rpn2//' -i tests/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export rd_cv_gcc_flag__Werror=no
+ export rd_cv_ms_async=ok
+ export RRDDOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+
+ # Bug #260380
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
+
+ # Enabling '-ffast-math' is known to cause problems.
+ filter-flags -ffast-math
+
+ # We will handle Lua bindings ourselves, upstream is not multi-impl-ready
+ # and their Lua-detection logic depends on having the right version of the Lua
+ # interpreter available at build time.
+ local myeconfargs=(
+ --disable-lua
+ --disable-ruby
+ --disable-ruby-site-install
+ $(usex !dbi '--disable-libdbi' '')
+ $(usex !examples '--disable-examples' '')
+ $(use_enable graph rrd_graph)
+ $(use_enable perl perl-site-install)
+ $(use_enable perl)
+ $(use_enable python)
+ $(usex !rados '--disable-librados' '')
+ $(usex !rrdcached '--disable-rrdcached' '')
+ $(use_enable rrdcgi)
+ $(use_enable static-libs static)
+ $(usex !tcpd '--disable-libwrap' '')
+ $(use_enable tcl)
+ $(use_enable tcl tcl-site)
+ $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir))
+ --with-perl-options="INSTALLDIRS=vendor"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}"/bindings/lua || die
+
+ # We do need the CMOD-dir path here, otherwise libtool complains.
+ # Use the real one (i.e. not within ${ED}) just in case.
+ local myemakeargs=(
+ LUA_CFLAGS="$(lua_get_CFLAGS)"
+ LUA_INSTALL_CMOD="$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd || die
+}
+
+python_compile() {
+ cd bindings/python || die
+ distutils-r1_python_compile
+}
+
+src_compile() {
+ default
+
+ # Only copy sources now so that we do not
+ # trigger librrd compilation multiple times.
+ if use lua; then
+ lua_copy_sources
+ lua_foreach_impl lua_src_compile
+ fi
+
+ use python && distutils-r1_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}"/bindings/lua || die
+ LUA_CPATH="${PWD}/.libs/?.so" emake LUA="${LUA}" test
+ popd || die
+}
+
+src_test() {
+ export LC_ALL=C
+ default
+
+ if use lua; then
+ lua_foreach_impl lua_src_test
+ fi
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}"/bindings/lua || die
+
+ # This time we must prefix the CMOD-dir path with ${ED},
+ # so that make does not try to violate the sandbox.
+ local myemakeargs=(
+ LUA_INSTALL_CMOD="${ED}/$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd || die
+}
+
+python_install() {
+ cd bindings/python || die
+ distutils-r1_python_install
+}
+
+src_install() {
+ default
+
+ if ! use doc; then
+ rm -rf "${ED}"/usr/share/doc/"${PF}"/{html,txt} || die
+ fi
+
+ if use lua; then
+ lua_foreach_impl lua_src_install
+ fi
+
+ if use perl; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+
+ use python && distutils-r1_src_install
+
+ if use rrdcached; then
+ newconfd "${FILESDIR}"/rrdcached.confd-r1 rrdcached
+ newinitd "${FILESDIR}"/rrdcached.init-r1 rrdcached
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}