summaryrefslogtreecommitdiff
path: root/net-analyzer/rain/rain-1.2.9_beta1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-analyzer/rain/rain-1.2.9_beta1-r1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-analyzer/rain/rain-1.2.9_beta1-r1.ebuild')
-rw-r--r--net-analyzer/rain/rain-1.2.9_beta1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/rain/rain-1.2.9_beta1-r1.ebuild b/net-analyzer/rain/rain-1.2.9_beta1-r1.ebuild
new file mode 100644
index 000000000000..84351e1ba87e
--- /dev/null
+++ b/net-analyzer/rain/rain-1.2.9_beta1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${P/_/}
+MY_P=${MY_P/-/_}
+DESCRIPTION="powerful tool for testing stability of utilizing IP protocols"
+HOMEPAGE="http://www.mirrors.wiretapped.net/security/packet-construction/rain/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SRC_URI="
+ mirror://ubuntu/pool/universe/r/${PN}/${MY_P}.orig.tar.gz
+ mirror://ubuntu/pool/universe/r/${PN}/${MY_P}-1.diff.gz
+"
+
+DOCS=( BUGS CHANGES README TODO )
+S="${WORKDIR}/${MY_P/_/-}"
+PATCHES=(
+ "${WORKDIR}"/${MY_P}-1.diff
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-die-on-error.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}