summaryrefslogtreecommitdiff
path: root/net-analyzer/portmon/portmon-2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-analyzer/portmon/portmon-2.0-r1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-analyzer/portmon/portmon-2.0-r1.ebuild')
-rw-r--r--net-analyzer/portmon/portmon-2.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/portmon/portmon-2.0-r1.ebuild b/net-analyzer/portmon/portmon-2.0-r1.ebuild
new file mode 100644
index 000000000000..824a242bbd0c
--- /dev/null
+++ b/net-analyzer/portmon/portmon-2.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Portmon is a network service monitoring daemon"
+HOMEPAGE="http://aboleo.net/software/portmon/"
+SRC_URI="http://aboleo.net/software/portmon/downloads/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_configure() {
+ econf --sysconfdir=/etc/portmon
+}
+
+src_install() {
+ into /usr
+ dosbin src/portmon
+
+ doman extras/portmon.8
+
+ insinto /etc/portmon
+ doins extras/portmon.hosts.sample
+ dodoc AUTHORS BUGS README
+
+ newinitd "${FILESDIR}"/portmon.init portmon
+}