summaryrefslogtreecommitdiff
path: root/net-analyzer/packit/packit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-analyzer/packit/packit-9999.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-analyzer/packit/packit-9999.ebuild')
-rw-r--r--net-analyzer/packit/packit-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/packit/packit-9999.ebuild b/net-analyzer/packit/packit-9999.ebuild
new file mode 100644
index 000000000000..d58eaf300f88
--- /dev/null
+++ b/net-analyzer/packit/packit-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="network packet generator and capture tool"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/packit"
+EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/packit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-noopt.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc docs/*
+}