summaryrefslogtreecommitdiff
path: root/net-analyzer/packit/packit-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /net-analyzer/packit/packit-1.6.1.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'net-analyzer/packit/packit-1.6.1.ebuild')
-rw-r--r--net-analyzer/packit/packit-1.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/packit/packit-1.6.1.ebuild b/net-analyzer/packit/packit-1.6.1.ebuild
new file mode 100644
index 000000000000..cd4fb1dfab52
--- /dev/null
+++ b/net-analyzer/packit/packit-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="network packet generator and capture tool"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/packit"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-noopt.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc docs/*
+}