summaryrefslogtreecommitdiff
path: root/net-analyzer/ostinato
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
commitd51fe7680c5270ddf8d324bbe11caab6d1e27ade (patch)
treea895b5889d79dbbb9aa52995fcac4816acfa07c1 /net-analyzer/ostinato
parent7d52991b5dce3a07be15d3cbbf06abb3fc08cb9c (diff)
gentoo auto-resync : 21:08:2023 - 21:44:47
Diffstat (limited to 'net-analyzer/ostinato')
-rw-r--r--net-analyzer/ostinato/Manifest2
-rw-r--r--net-analyzer/ostinato/ostinato-1.2.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/Manifest b/net-analyzer/ostinato/Manifest
index cfac08bee8c4..2ec7120ba3a3 100644
--- a/net-analyzer/ostinato/Manifest
+++ b/net-analyzer/ostinato/Manifest
@@ -1,4 +1,6 @@
AUX ostinato-0.9_p20180522-no-modeltest.patch 243 BLAKE2B bf382374a803ac4be4e9b00e216ce61c918e3f097b3034337fdeeadeb131e7a0ed8b028b1b08f107d94438baad35be6d7606874439850ddb9f0e5176ffa28a15 SHA512 b82fed38f8b4bccca3e6de599508c1c65c8bcf83dc88ca6e4c383f04eadc6fa3c3bfd2ddf31e5eaa26b8445f674e76600712659705bd2061a1ed0646af022c6b
DIST ostinato-1.1.tar.gz 612589 BLAKE2B 2244b3be5649e0623139b667c61a169a3e7f5dae6f022d6550cd825f1af8fa2c2d82210af1f381ae53af19fff9a56d58b30a406fc1f3d89c73bc7e3d0ab18fa4 SHA512 a45e157d155d4f2efe9a1594a140647b5cbd7264985b15a9ed47d86198c9df9d763170097dcfd40fae1317206e53c9155f08c48c747cce458e0cae7f3a841449
+DIST ostinato-1.2.0.tar.gz 1169889 BLAKE2B 73d1ba4801ee8f50757fbe3a5e4c6fb67957296326c5ffcc5ecfde723ee975bd6a8f494644198b4b47a296fd087e2ed7a43088facd8c39d3ed70b8056fae5da5 SHA512 c3fb1f63a8f32c199ae2c8630244a3d6110e25e9117fbc96b009fd54d6bc16dbfa120b2d26c474ca06e86dbed59a5051443f82064fb8a0eda2feb212e4e1a1c5
EBUILD ostinato-1.1-r2.ebuild 843 BLAKE2B 8bf98c6de835ee405126378ade475c14d92547bc3b597e387c41cdfcdfc335f9682de20a51a802c1c2a8118555b14858ffcc59d21b52d0801005c94992fdf226 SHA512 c5cec6152d0a1ef4973efe94a680d0a3a05e171a716914783fb1f4d6793ae34e9b6df19ced5e88dda5d1e5f14477e798ddbaec3b832fc7e4e60d871e3a96d0c6
+EBUILD ostinato-1.2.0.ebuild 972 BLAKE2B 1b2f3382afc569bcbb18f12cba00ef27429cea5c2fa63539f6a1e27118a714d8497f65dcf90d07072e25cd39d623809f6ff8a19c73003630f163d677cb0d84ff SHA512 d9526fb6b70d2123facd68e74f88c4b227561c173d52fe1ab7195efe9b9c93a03e7bf469dc1f42db7ba6b0912f80a9da3855918122eefe0e964f9a0d45e38228
MISC metadata.xml 330 BLAKE2B d7fd03dae0df59956949953d5d9a18111ef8866c43908cfa09248e7ef2966407b879f5357fb5d6a427710f90fdb36f556bcdc359a7b93a8503e9d69db47a6aa5 SHA512 f27cd8dcddb1ca6f5721edacd8acd4b94042ace9a7800ab9601cefda00b0658ba18e200c14ad2cec02240b8eda6c58eec881c018175f94f8db5e46214f1bc149
diff --git a/net-analyzer/ostinato/ostinato-1.2.0.ebuild b/net-analyzer/ostinato/ostinato-1.2.0.ebuild
new file mode 100644
index 000000000000..586f8e2f2597
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Packet generator and analyzer"
+HOMEPAGE="https://ostinato.org/"
+SRC_URI="https://github.com/pstavirs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#https://github.com/pstavirs/ostinato/issues/173
+# libpcap dep is versioned to pull in the fix for #602098
+RDEPEND="
+ dev-libs/protobuf:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-libs/libnl:3
+ >=net-libs/libpcap-1.8.1-r2
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtsvg:5
+ dev-qt/qtxml:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9_p20180522-no-modeltest.patch"
+)
+
+src_configure() {
+ sed -i 's#"/drone"#"/ostinato-drone"#' client/mainwindow.cpp || die
+ eqmake5 PREFIX="/usr" ost.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+ mv "${ED}"/usr/bin/{drone,ostinato-drone}
+}