summaryrefslogtreecommitdiff
path: root/net-analyzer/openvas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /net-analyzer/openvas
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'net-analyzer/openvas')
-rw-r--r--net-analyzer/openvas/Manifest3
-rw-r--r--net-analyzer/openvas/metadata.xml20
-rw-r--r--net-analyzer/openvas/openvas-9.0.0.ebuild47
3 files changed, 65 insertions, 5 deletions
diff --git a/net-analyzer/openvas/Manifest b/net-analyzer/openvas/Manifest
index adb102e85b7b..edd750c4e7e6 100644
--- a/net-analyzer/openvas/Manifest
+++ b/net-analyzer/openvas/Manifest
@@ -1,3 +1,4 @@
AUX README.gentoo 1029 BLAKE2B e44091e9ea96dd210d0e31033212893c8197bff4393b8cb6a4ce38bc53ed43b8ecad649f8b47683346c0c353c7c06e29e64d298be19ba0fc8db2d0d36411b2cf SHA512 aeff351d306e4bc818b48d254c9efd618818b9ae1025285e97105908746628db469b4fa4620cb0db3032f58f50f3615779cf35c098e3e7819c01c24ee0adefc5
EBUILD openvas-8.0.5-r1.ebuild 1460 BLAKE2B 4e0553cdf1cdd6055e7940d96c5e2336d557f09dbcbac2ca23f78e38cfe6062e6926a79c4afdd0f0d5fbf1a0659c0866e5e0cabc23958a36a974c25ad38181a3 SHA512 46582e09a8bada805ec596ff3d11493a678d33b5133b815b4812a5258733853af3f42664657d98e53ad8de47ad1f3e7bf404ea8b63406e25d8ca7f91ae564d30
-MISC metadata.xml 238 BLAKE2B b91a7f19a4d87dcd97331129a73b88ef7b3e61da88b6e2b1832cbc8e5f6feee8c1e178ba49315486bbd64bc5fe374ce6adfb2e7d3d93d797abfd92569faa6b84 SHA512 25c65cad6aecb4c0b9c49ab598ede40d984bfec04205e28255db36e9f4a0c3dd26d20f4a9f6fe93b7c5503925b81fe7e9ea58afb5805ad08f2f24b2565073a8b
+EBUILD openvas-9.0.0.ebuild 1746 BLAKE2B 75c0b78b5d8bf6f39a08f0bb4db2b076fd3572d4b3a8517e75147d692cbe25efd4c8207db278af05f075135e206771deebd078cff77390efbed0a398cd1b1074 SHA512 bc70bd027e30df3216c290e63e6dbf4ebca0714b36b4fb97a2c0e5de06162915f1af41d0d17669484a8996163c3ab19b5af6b69ff4a6c9e1e64ef869f64c1d79
+MISC metadata.xml 990 BLAKE2B 38d5a08041cad530d89c9f7f93e6e45718fcc5358d71b72e664d249ae20f6b60502fbf00a0bf5b510c7e12192b5d696b3b262083b55389e36be6b9b6b22b4843 SHA512 897ec95d4a7b86a91fe5ced1dfbf27b724ec3a5c1a83ebdc2dfae76d707013d2ac2d908a341e36f950c0bf125d3010fab4bb58012a650be8bcd988c0d14821c2
diff --git a/net-analyzer/openvas/metadata.xml b/net-analyzer/openvas/metadata.xml
index 38b8343826ee..a2806dd34dca 100644
--- a/net-analyzer/openvas/metadata.xml
+++ b/net-analyzer/openvas/metadata.xml
@@ -1,8 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
- <use>
- <flag name="pdf">Enable pdf report creation</flag>
- </use>
+ <maintainer type="person">
+ <email>hasan.calisir@psauxit.com</email>
+ <name>Hasan ÇALIŞIR</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="extras">Extra fonts, pdf results and html docs support</flag>
+ <flag name="cli">Command Line Interface for OpenVAS Scanner throught <pkg>net-analyzer/gvm-tools</pkg></flag>
+ <flag name="gsa">Greenbone Security Assistant (WebUI) through <pkg>net-analyzer/greenbone-security-assistant</pkg></flag>
+ <flag name="ospd">Enable support for scanner wrappers through <pkg>net-analyzer/ospd</pkg></flag>
+ <flag name="ldap">Enable support for ldap through <pkg>net-nds/openldap</pkg></flag>
+ <flag name="radius">Enable support for radius through <pkg>net-dialup/freeradius-client</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/net-analyzer/openvas/openvas-9.0.0.ebuild b/net-analyzer/openvas/openvas-9.0.0.ebuild
new file mode 100644
index 000000000000..f7bf53cc8a19
--- /dev/null
+++ b/net-analyzer/openvas/openvas-9.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cli +extras +gsa ldap +ospd radius"
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-9.0.3
+ >=net-analyzer/openvas-manager-7.0.3
+ >=net-analyzer/openvas-scanner-5.1.3
+ cli? ( >=net-analyzer/gvm-tools-1.4.1 )
+ extras? (
+ >=net-analyzer/openvas-libraries-9.0.3[extras]
+ >=net-analyzer/openvas-manager-7.0.3[extras]
+ >=net-analyzer/openvas-scanner-5.1.3[extras]
+ )
+ gsa? ( >=net-analyzer/greenbone-security-assistant-7.0.3
+ extras? ( >=net-analyzer/greenbone-security-assistant-7.0.3[extras] )
+ )
+ ldap? ( >=net-analyzer/openvas-libraries-9.0.3[ldap] )
+ ospd? ( >=net-analyzer/ospd-1.3.2
+ extras? ( >=net-analyzer/ospd-1.3.2[extras] )
+ )
+ radius? ( >=net-analyzer/openvas-libraries-9.0.3[radius] )"
+
+pkg_postinst() {
+ elog "----------------------------IMPORTANT----------------------------"
+ elog " Please read important notes > /usr/share/openvas/OPENVAS.gentoo "
+ elog "-----------------------------------------------------------------"
+ elog "Additional support for extra checks can be get from"
+ optfeature "Web server scanning and testing tool" net-analyzer/nikto
+ optfeature "Portscanner" net-analyzer/nmap
+ optfeature "IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "Application protocol detection tool" net-analyzer/amap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "Web application attack and audit framework" net-analyzer/w3af
+}