summaryrefslogtreecommitdiff
path: root/net-analyzer/ntopng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /net-analyzer/ntopng
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/Manifest2
-rw-r--r--net-analyzer/ntopng/ntopng-5.0.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/Manifest b/net-analyzer/ntopng/Manifest
index 5f3dc547a594..117da5e87e91 100644
--- a/net-analyzer/ntopng/Manifest
+++ b/net-analyzer/ntopng/Manifest
@@ -6,5 +6,7 @@ AUX ntopng-4.2-parallel-make.patch 352 BLAKE2B e2411060d85820b0808c735cabdeb1f4e
AUX ntopng.conf.d 117 BLAKE2B 67e2962fcb0303ab465b3d8def04192992e3e7306c5e76084a58cca5bdf1a797b08193f2a3512f876ff9c5300b0f3504055e7166afcbb4cbc527658c74b0616b SHA512 bb66d11245ce099f9e09f97d830da60df910682242db0c5c7d17bcd800e84cf3bce6288fb75fc3a8f3e214a580dc0d076f7f69aa924d9ad3e4c8bff093252061
AUX ntopng.init.d 549 BLAKE2B de561950f001e35a26b522728affa5971d8a0fdd1d855746509c0e6861df7ed9c356abe6bc066df65524c340d05c072e7c4de0864c250164b8a1509b34d508c0 SHA512 1fbcc46fe10dcef82a1310d74c4351c72752cdd2a9b9908705c8c645698430e456f1ba14b77fd7c1f374a237a508c2d33324de61f5f1f8255ed75a384e874d84
DIST ntopng-4.2.tar.gz 57554819 BLAKE2B a9eaf7ea670dbd9c830696a4b017330e25a82307852a0a85d95ddbb4e32a3123d43eda1b686c359da1fef77e601cd3791dcdf257141e2e1d3ed7974b92edaac8 SHA512 e89ec3f35644ae8bc570d9802ecfadbf0067145e23a589df2032e8781e9c954f4166d3abb650ddafc65e4fbad656730ee1abf9c5273d3e09f8173d423436b8ff
+DIST ntopng-5.0.tar.gz 57935381 BLAKE2B 420bda10ecc264d6baea0714367e8c475e72480ab1a114251c6712535ad1415288154623aa3ef780a5bab55bec684ddd7c0582997654f8fbb96ec08e17cb099f SHA512 e157430d9c98871d0136d2f51af6c7fed3a95fa21f8d3a9447ee69ac2aaee3752b6eddfd584715e3ee36234fd0fdcf865b761b0ec1a08727f6d988bc115d21e6
EBUILD ntopng-4.2-r1.ebuild 2007 BLAKE2B 11fc39c77829db81cee9c8f598151a0ba056dd40f03482f042cd8885ba81c4237a07addc8100cc65ceeb366e6411a5ee819c51131b614e4c0c4cd45496ecd9b2 SHA512 64371bfa4a1ba20b5650ab65f4f673b85e98704b4a8cac59751eea645d870d9f63a68480ce2fefcd12075bfe06768771fc2d735c6973fde0bb087b62ee36c780
+EBUILD ntopng-5.0.ebuild 1928 BLAKE2B 4f105b044967cf595e184229e4dd5dee5b03a6c453d00c16478d05f18fced9517c8954c75aae25b45cc30701512313bd9e717f95c6bdffbb0c8037168a0883ef SHA512 573cb8e2cb1db7652788451a428acc0b92bcf34937a2521bea8d5305be9149770e3c8c3f7fa0e94f422bb09ff1574c3aeec32c43d4bb9fcc0910967c35a7b892
MISC metadata.xml 295 BLAKE2B 2b7f20f08d1cef4e5cfa80981f282a4907a8496b565a1a146f27a3d8736653d35c6b03e07299b0b4bbbb32100d01c873c683b90ca96bed98e85cfd71a6175ddf SHA512 4d5b0f4892ca44c672c5f9b1291a91fb3333b36830df22432df5cfed48e3c6c93ca88a0675a50fd33013d7f01805df99d474e8c98b9c94f3c878366b32d5bc6f
diff --git a/net-analyzer/ntopng/ntopng-5.0.ebuild b/net-analyzer/ntopng/ntopng-5.0.ebuild
new file mode 100644
index 000000000000..e879c8456307
--- /dev/null
+++ b/net-analyzer/ntopng/ntopng-5.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-db/mysql-connector-c:=
+ dev-db/sqlite:3
+ dev-libs/hiredis:=
+ dev-libs/json-c:=
+ dev-libs/libmaxminddb
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ net-analyzer/rrdtool
+ net-libs/libpcap
+ >=net-libs/nDPI-3.0:=
+ >=net-libs/zeromq-3:=
+ net-misc/curl
+ sys-libs/libcap
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ acct-user/ntopng
+ acct-group/ntopng
+ dev-db/redis"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2-mysqltool.patch
+ "${FILESDIR}"/${PN}-4.2-parallel-make.patch
+ "${FILESDIR}"/${PN}-4.0-ndpi-includes.patch
+)
+
+src_prepare() {
+ default
+
+ # Follows upstream's autogen.sh
+ sed \
+ -e "s/@VERSION@/${PV}.$(date +%y%m%d)/g" \
+ -e "s/@SHORT_VERSION@/${PV}/g" \
+ -e "s/@GIT_DATE@/$(date)/g" \
+ -e "s/@GIT_RELEASE@/${PV}.$(date +%y%m%d)/g" \
+ -e "s/@GIT_BRANCH@//g" < "${S}/configure.seed" \
+ > "${S}/configure.ac" || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ MYCFLAGS="${CFLAGS}" \
+ MYLDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
+ insinto "${SHARE_NTOPNG_DIR}"
+ doins -r httpdocs
+ doins -r scripts
+
+ insinto "${SHARE_NTOPNG_DIR}/third-party"
+ doins -r third-party/i18n.lua-master
+ doins -r third-party/lua-resty-template-master
+
+ exeinto /usr/bin
+ doexe "${PN}"
+ doman "${PN}.8"
+
+ newinitd "${FILESDIR}"/ntopng.init.d ntopng
+ newconfd "${FILESDIR}"/ntopng.conf.d ntopng
+
+ keepdir /var/lib/ntopng
+ fowners ntopng /var/lib/ntopng
+}
+
+pkg_postinst() {
+ elog "ntopng default credentials are user='admin' password='admin'"
+}