summaryrefslogtreecommitdiff
path: root/net-analyzer/ntopng/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-03 21:11:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-03 21:11:18 +0000
commit8ba493f5439ffec0ed21707f660602b7bd80bbbf (patch)
treea103c65926b64945179cd7435d608e9c761ebaf3 /net-analyzer/ntopng/files
parentdc50ce612ba7a32ca77479875798989da2885437 (diff)
gentoo auto-resync : 03:02:2023 - 21:11:18
Diffstat (limited to 'net-analyzer/ntopng/files')
-rw-r--r--net-analyzer/ntopng/files/ntopng-5.4-ndpi-linking.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/files/ntopng-5.4-ndpi-linking.patch b/net-analyzer/ntopng/files/ntopng-5.4-ndpi-linking.patch
new file mode 100644
index 000000000000..8a50b7cb1a10
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-5.4-ndpi-linking.patch
@@ -0,0 +1,49 @@
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -231,31 +231,8 @@ NDPI_LIB=
+ NDPI_LIB_DEP=
+
+ AC_MSG_CHECKING(for nDPI source)
+- if test -d "./nDPI" ; then :
+- NDPI_HOME=./nDPI
+- elif test -d "../nDPI" ; then :
+- NDPI_HOME=../nDPI
+- elif test -d "$HOME/nDPI" ; then :
+- NDPI_HOME=$HOME/nDPI
+- fi
+-
+- if test ! -z "$NDPI_HOME" ; then :
+- AC_MSG_RESULT(found in $NDPI_HOME)
+- NDPI_LIB=$NDPI_HOME/src/lib/libndpi.a
+- AC_MSG_CHECKING(for $NDPI_LIB)
+- if test -r $NDPI_LIB ; then :
+- AC_MSG_RESULT(found $NDPI_LIB)
+- else
+- AC_MSG_RESULT(not found $NDPI_LIB: compiling)
+- cd $NDPI_HOME; ./autogen.sh; ${MAKE}; cd -
+- fi
+- NDPI_INC="-I$NDPI_HOME/src/include -I$NDPI_HOME/src/lib/third_party/include"
+- NDPI_LIB=$NDPI_HOME/src/lib/libndpi.a
+- NDPI_LIB_DEP=$NDPI_LIB
+- else
+- AC_MSG_RESULT(not found)
+- fi
+-
++ NDPI_LIB="-lndpi"
++ NDPI_LIB_DEP=$NDPI_LIB
+
+ if test ! -z "$NDPI_CUST_INC" ; then :
+ NDPI_INC=$NDPI_CUST_INC
+diff --git a/configure.ac.in b/configure.ac.in
+index ed906b1..3e70bec 100644
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -242,7 +242,7 @@ if test ! -z "$NDPI_CUST_LIB" ; then :
+ NDPI_LIB=$NDPI_CUST_LIB
+ fi
+
+-if test -z "$NDPI_INC" || test -z "$NDPI_LIB" ; then :
++if test -z "$NDPI_LIB" ; then :
+ echo "Could not find nDPI"
+ echo "Please do cd ..; git clone https://github.com/ntop/nDPI.git; cd nDPI; ./autogen.sh; ${MAKE}; cd ../ntopng"
+ echo "and try again"