summaryrefslogtreecommitdiff
path: root/net-analyzer/nikto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-analyzer/nikto
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-analyzer/nikto')
-rw-r--r--net-analyzer/nikto/Manifest3
-rw-r--r--net-analyzer/nikto/metadata.xml12
-rw-r--r--net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
new file mode 100644
index 000000000000..eee995aa8e10
--- /dev/null
+++ b/net-analyzer/nikto/Manifest
@@ -0,0 +1,3 @@
+DIST nikto-2.1.6_p20200901.tar.gz 521285 BLAKE2B 243f0baf5835e5586b8270fc9dd1005c08e903f478666359c34bb0d30c0645f5ab9a19109718dbbd2f6015dcb64c3a98b832b5412c9151720dedd102fb1936d1 SHA512 88b9e681ce4588e3473f90c93ea41d46fc99a54b895185465cfe1a28152ad944edbadfcf5cee4540b4ec48eb78ca73a1952637c3da9038e52d837c0de5d0260c
+EBUILD nikto-2.1.6_p20200901.ebuild 1112 BLAKE2B b3969fd79c055b84513820eff4d1c8b5675a8f40044be1d145f1421555153fc82ab1ef1f86d80fc5f38578c5d55139efeaa3d01e25228a7cfb51544c01ddf11d SHA512 182e2651e059a4d12e26bc7c49eb1555364d7a536879d86312efe91a518ad10f4c7c16652c9a356a2c9bf0deebacb8b868d729d6fa7f4bd554ef31dfa7d4f35c
+MISC metadata.xml 368 BLAKE2B 1b830b9fc3837ed7b4706a646f08e1edb316c264b82232740467c341b54c14d49d4dd936d8c24c32256f3235dde2ee5ebbdfadb0fb117136d5e49af353590fab SHA512 2f1a7954d7f6360a4b83f22933cb45e800ab2fc7a7725569736fcc4e64d3d3603dcc64a0ebe888ebb824a51fef81d7220599f525a8e316df762e874ccbd51efd
diff --git a/net-analyzer/nikto/metadata.xml b/net-analyzer/nikto/metadata.xml
new file mode 100644
index 000000000000..91f5940d4d0a
--- /dev/null
+++ b/net-analyzer/nikto/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@retornaz.com</email>
+ <name>Quentin Retornaz</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild b/net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild
new file mode 100644
index 000000000000..5d64088ea896
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+COMMIT="fb2655b8316097723d4977c792817a21117b2736"
+MY_P="${PN}-${COMMIT}"
+SRC_URI="https://github.com/sullo/nikto/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${MY_P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ dodoc docs/*.txt
+ dodoc docs/nikto_manual.html
+}