summaryrefslogtreecommitdiff
path: root/net-analyzer/nikto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /net-analyzer/nikto
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'net-analyzer/nikto')
-rw-r--r--net-analyzer/nikto/Manifest2
-rw-r--r--net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
index 5053ce1da9d2..995a5f17a770 100644
--- a/net-analyzer/nikto/Manifest
+++ b/net-analyzer/nikto/Manifest
@@ -1,3 +1,5 @@
DIST nikto-2.1.6_p20200901.tar.gz 521285 BLAKE2B 243f0baf5835e5586b8270fc9dd1005c08e903f478666359c34bb0d30c0645f5ab9a19109718dbbd2f6015dcb64c3a98b832b5412c9151720dedd102fb1936d1 SHA512 88b9e681ce4588e3473f90c93ea41d46fc99a54b895185465cfe1a28152ad944edbadfcf5cee4540b4ec48eb78ca73a1952637c3da9038e52d837c0de5d0260c
+DIST nikto-2.1.6_p20210304.tar.gz 521719 BLAKE2B 66715e109dfb47bb5ed6b64cfff4dbdd0667883e5ce28c26a7325645fe42ccfdcb6f9bcf956adce6f626c51ff363122724955eda86c715d4f8ec4894ebf1ae4a SHA512 d78cedad0b2f96d02964097699d5765fdb895b7ec1a9e196cbf9181888dd19cfca7d912f172a870e4b8bd2b53e4fc41407a60ed129ef24592909ef6111d04a0e
EBUILD nikto-2.1.6_p20200901.ebuild 1101 BLAKE2B e1a67234ccdb86ba5f58bf6a7e639d7d7a838066f422333c75c91ff724805f5bf5c364ad70f51aa411e7927435644feb68fb45b8909a06e993ef38503a3b8cd0 SHA512 69a4b4ac1a8a07d13975999b46cc43ca768fe44d8c2c6af27187aa1f3e0ac7c8f457c52ff6d6956238096369422cb476e7e4cac51b9d49061314f25293d2e8a9
+EBUILD nikto-2.1.6_p20210304.ebuild 1101 BLAKE2B 0a6e63c0bff031c54951ada0f3569a8deaa8237cfaac8409ea53bc487ec96c91841e0bc4d4b4758425adbbe86e3ac9ee727ea4629dd6dc2abaf18d6733aec4ef SHA512 bcfa7414aac47ba18bbbdfa196067740a6d998bda53f7547c5e9d8360b17f2beff7462520282382c12ad410b787b4a1400de60b6a64242cd5290e8b2df09a5f9
MISC metadata.xml 368 BLAKE2B 1b830b9fc3837ed7b4706a646f08e1edb316c264b82232740467c341b54c14d49d4dd936d8c24c32256f3235dde2ee5ebbdfadb0fb117136d5e49af353590fab SHA512 2f1a7954d7f6360a4b83f22933cb45e800ab2fc7a7725569736fcc4e64d3d3603dcc64a0ebe888ebb824a51fef81d7220599f525a8e316df762e874ccbd51efd
diff --git a/net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild b/net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild
new file mode 100644
index 000000000000..4465e68730cd
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+COMMIT="8a4b5fb86ae8a1b4f31c32da0bcedd3bcaf4deb8"
+MY_P="${PN}-${COMMIT}"
+SRC_URI="https://github.com/sullo/nikto/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${MY_P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ dodoc docs/*.txt
+ dodoc docs/nikto_manual.html
+}