summaryrefslogtreecommitdiff
path: root/net-analyzer/netselect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-analyzer/netselect
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-analyzer/netselect')
-rw-r--r--net-analyzer/netselect/Manifest1
-rw-r--r--net-analyzer/netselect/netselect-9999.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/netselect/Manifest b/net-analyzer/netselect/Manifest
index bc0209fa1c9d..42fda23795f3 100644
--- a/net-analyzer/netselect/Manifest
+++ b/net-analyzer/netselect/Manifest
@@ -3,4 +3,5 @@ AUX netselect-0.4-flags.patch 172 BLAKE2B 17acc10b64404c9d8525147f5ca526f661a2b2
DIST netselect-0.4-ipv6.patch.xz 18272 BLAKE2B 6197057085e892c156a9fb3a82ac0030a2ff1b4276dde48405de2d2bcfdcef066c4f3eeff174f766af23d2807085f97e459dbffc87b2a2950a472e7964f2e3fc SHA512 422b54df5be45379fe7d6776b6e653a8e49df6fb77421527f2eb6c687597f36cccc7ab5cc5206e9823c318f6facd84fb4e8c0dbffbf9641cee593401cb73abea
DIST netselect-0.4.tar.gz 22095 BLAKE2B 1dd83c4dcd38ab7b987ead76f4e7e727980bbad91b59c56948e13540307e685984cc11ea94292d38959c8253f1f6ec2e6e6e044302f26b09153717d6e29e96be SHA512 eee9639122b7cc89218c610794d090582aecb3df138bcef41472c8d40c0f7e998b2c4b04aace13795fda5c710ee28cc2c0784a680ad6d1aa6a14eb441a408bfa
EBUILD netselect-0.4-r1.ebuild 971 BLAKE2B 763fdcf48e8117f6aee40abae77518e1368ef14cff7b11aac8d635b018dc5b88a99500963e41291618e2968a38123298ab78fd4a99f4f53814bd121ab1404653 SHA512 c827f560baefb52e52775043e610eb4baac9872dd323e0cc7a2bf0347c198fe554f5b1991eead44bdf8c4b100df7fa9fe9ae986bc3bd7a8f49d55975c5ad6de0
+EBUILD netselect-9999.ebuild 900 BLAKE2B 581801a56b90a1a856796e0995c6bd4037d52fd14eeb2e1aad47eaf980c0996d8a865b1e95429bd0913e750b4bd0ded217a4ec8a00b308c1a81f02305c6651f6 SHA512 c2619dacf3aba239f68a245ef283f1a7839fcc639fafcd41e8acbebf36e11396997074faab2e36a61c71c0a7665a695f0df838f351bf95a321cabf9a45493b0f
MISC metadata.xml 276 BLAKE2B e21811549278e73aa9a14acfe242fd022106a39ac1300caa00615772d7f54d08a433052659a271f9ac0d453c7776fc2b9e8d86e6d3f637817c214174dde52cb2 SHA512 f0e6c6bc89659e01e157d9bf30d0a2f3fd2d71bc26c8d12489c4a44fc5237159946e25b46e7295ab4676aea63559194977a0b1e76aced31d81cf6387dd0f4250
diff --git a/net-analyzer/netselect/netselect-9999.ebuild b/net-analyzer/netselect/netselect-9999.ebuild
new file mode 100644
index 000000000000..de08fdebbdfa
--- /dev/null
+++ b/net-analyzer/netselect/netselect-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping"
+HOMEPAGE="http://apenwarr.ca/netselect/"
+EGIT_REPO_URI="
+ https://github.com/apenwarr/${PN}
+"
+SRC_URI="
+ ipv6? ( https://dev.gentoo.org/~jer/${PN}-0.4-ipv6.patch.xz )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="ipv6"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-bsd.patch
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+
+src_unpack() {
+ use ipv6 && unpack ${A}
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ use ipv6 && PATCHES+=( "${WORKDIR}"/${PN}-0.4-ipv6.patch )
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ dobin netselect
+
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+
+ dodoc HISTORY README
+
+ doman netselect.1
+}