summaryrefslogtreecommitdiff
path: root/net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
commit4e0f61672a4cd8a3d8afc21e9afc2a7acd849976 (patch)
tree20cba6f816bb34fdd956935e64d4432ed2427c65 /net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild
parentd479c9c5c724c7b1300a98e44975f31f4f2e51dd (diff)
gentoo auto-resync : 07:12:2022 - 03:12:11
Diffstat (limited to 'net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild')
-rw-r--r--net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild b/net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild
new file mode 100644
index 000000000000..1cda1d25fa4a
--- /dev/null
+++ b/net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="NetPIPE"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="network protocol independent performance evaluator"
+HOMEPAGE="http://bitspjoule.org/netpipe/"
+SRC_URI="http://bitspjoule.org/netpipe/code/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ipv6"
+
+DOCS=(
+ bin/feplot
+ bin/geplot
+ bin/nplaunch
+ dox/README
+ dox/netpipe_paper.ps
+ dox/np_cluster2002.pdf
+ dox/np_euro.pdf
+)
+
+PATCHES=( "${FILESDIR}"/${P}-fix-makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake memcpy tcp $(usev ipv6 tcp6)
+}
+
+src_install() {
+ dobin NPmemcpy NPtcp $(usev ipv6 NPtcp6)
+ doman dox/netpipe.1
+ einstalldocs
+}