summaryrefslogtreecommitdiff
path: root/net-analyzer/netdata
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 01:09:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 01:09:33 +0000
commit58523314abd7b5740c06e3bbcd41ada404e7c612 (patch)
tree2ec4372c4b63bd8679af9b4c591c2743e421b1b9 /net-analyzer/netdata
parent4fc30e4e13ecfbe29fbef3b5caf96218eab30b68 (diff)
gentoo auto-resync : 13:01:2024 - 01:09:33
Diffstat (limited to 'net-analyzer/netdata')
-rw-r--r--net-analyzer/netdata/Manifest2
-rw-r--r--net-analyzer/netdata/netdata-1.44.0.ebuild7
2 files changed, 5 insertions, 4 deletions
diff --git a/net-analyzer/netdata/Manifest b/net-analyzer/netdata/Manifest
index 27e02d89c209..c624ae02232e 100644
--- a/net-analyzer/netdata/Manifest
+++ b/net-analyzer/netdata/Manifest
@@ -1,5 +1,5 @@
AUX netdata-1.44.0-dbengine.patch 1703 BLAKE2B 50af2960a6bf44361a5d9a0bd916c6909874211e170bd986794d901503e841fc3dd7ff1cbb5d2d97a86506b84d0bdc1a1199e3da6615d6f3e94486fba53eac31 SHA512 5b223f522bb25f5ace9e1622cd7d23526343c5499dccf10ea2353524d089134742b5cdf11c7f2f813844b0a96b8f469c485cccb282f49bd07e097108da2f085c
DIST netdata-1.44.0.tar.gz 47423685 BLAKE2B 2b430d07abed1e49c5b7a3c24188446e929301eecc849d03ee9c33860f13942dbc06453401d166195b1aadd16e28e19b7533d16fc10e6f3eca51117b52485a85 SHA512 ef3534351504385ac33e18917a839c6506c377a4f25246d8819da916c6e46ae3d2d6f5422e8a685fd3aabbf851829233943abce8a8aeba0ce94db011ed406602
-EBUILD netdata-1.44.0.ebuild 4194 BLAKE2B 2537be743e2f79d32e26178ef4383d31bd2f62c3569cc97f2cbe0dbe38cda4deaf06805cd05058032e8723f0431673fab68101fbed4a0971a9d2c6fb3be225ce SHA512 6d72c64347410e16a0e56e6a90f052a77e0f3b847e049a0bc260a1e90053c779466ce4183168bba7ab18d03648c746db6ae592bd7289cb1069ccb93a8e90dd13
+EBUILD netdata-1.44.0.ebuild 4211 BLAKE2B 7221dc851b930b76f7a90b8062025ee723fe5bff7f64a69afe3e857136d2277a0b0c51b516861b26848df9bd1fe9a0a12dc5c078a814e8c16bc42f63fa03641f SHA512 1d9249bbeddb683e00e2a0116e8452eaa62ca2fbcf78b38f89771e030cb6acd6e34bd610936018b2c63f643ecc425a20f4d30acd57d2b45a8c599086fb5a26a7
EBUILD netdata-9999.ebuild 4005 BLAKE2B c510ece3c310879633e991b2c3ef91511201f369aaceb86840dc1e433270c2d6aa93407fb3338bc2eda9886e50865778e7ccb080b834947e8cccf4cc02fb5379 SHA512 3c2ca2a440afe653e2f3c5068ff31c53b5ba674aee18ad8e2128f61df8c9e80e96b35de8155a398d878c421256ab06db372d4bc11e3adb69067fc9fe7caf97f2
MISC metadata.xml 1512 BLAKE2B 321d3c1be16a0fd3c64d89f96c510d68ea82fca12730183d2724f7a0f30fdcb94c2be2749a6f9651ae7effdf7c250e977f95cf03c865a20e03e136456429c2b3 SHA512 4bd5583efd1fee4a0f221708fedf6dcf424639852842c8ba1089a2303a57ae58ccfd302fc5fcbfdada65a56efa8c7c949b95eedde0133a770ef68ca6688bbefd
diff --git a/net-analyzer/netdata/netdata-1.44.0.ebuild b/net-analyzer/netdata/netdata-1.44.0.ebuild
index f0470bbdd4ca..a85bf1232c4b 100644
--- a/net-analyzer/netdata/netdata-1.44.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.44.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python{3_9,3_10,3_11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools fcaps flag-o-matic linux-info optfeature python-single-r1 systemd toolchain-funcs
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps cloud +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="caps cloud +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -105,6 +105,7 @@ src_configure() {
[[ $(tc-endian) == big ]] && append-flags -mno-vsx
fi
+ # --enable-lto only appends -flto
econf \
--localstatedir="${EPREFIX}"/var \
--with-user=netdata \
@@ -116,7 +117,7 @@ src_configure() {
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
--disable-exporting-kinesis \
- $(use_enable lto lto) \
+ --disable-lto \
$(use_enable mongodb exporting-mongodb) \
$(use_enable prometheus exporting-prometheus-remote-write) \
$(use_enable xen plugin-xenstat) \