summaryrefslogtreecommitdiff
path: root/net-analyzer/netdata/netdata-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-28 19:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-28 19:13:18 +0000
commit9173ac495b70d91abace8e732906b844522cdb3b (patch)
treed4dced96e0b1f492507e987b1ced7cf582a985e4 /net-analyzer/netdata/netdata-9999.ebuild
parentac4d0ec6279a51ce08af9e3293666bc339be6b6f (diff)
gentoo auto-resync : 28:03:2024 - 19:13:18
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 56ca10202a2c..2d2fe2aeb560 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="aclk bpf cloud cups +dbengine ipmi mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="aclk bpf cloud cups +dbengine ipmi mongodb mysql nfacct nodejs postgres prometheus +python systemd tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -78,7 +78,8 @@ RDEPEND="
xen? (
app-emulation/xen-tools
dev-libs/yajl
- )"
+ )
+ systemd? ( sys-apps/systemd )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -108,6 +109,7 @@ src_configure() {
-DENABLE_PLUGIN_XENSTAT=$(usex xen)
-DENABLE_PLUGIN_EBPF=$(usex bpf)
-DENABLE_PLUGIN_GO=FALSE
+ -DENABLE_PLUGIN_SYSTEMD_JOURNAL=$(usex systemd)
)
cmake_src_configure
}