summaryrefslogtreecommitdiff
path: root/net-analyzer/netdata/netdata-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /net-analyzer/netdata/netdata-9999.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 427b0ff777e1..3df5ef6ecd47 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python{3_8,3_9,3_10} )
inherit autotools fcaps flag-o-matic linux-info python-single-r1 systemd toolchain-funcs
@@ -10,8 +10,8 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/netdata/${PN}/releases/download/${PV}/${PN}-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${PV}"
+ SRC_URI="https://github.com/netdata/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
KEYWORDS="~amd64 ~ppc64 ~x86"
fi
@@ -109,10 +109,10 @@ src_configure() {
$(use_enable dbengine) \
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
- $(use_enable kinesis backend-kinesis) \
+ $(use_enable kinesis exporting-kinesis) \
$(use_enable lto lto) \
- $(use_enable mongodb backend-mongodb) \
- $(use_enable prometheus backend-prometheus-remote-write) \
+ $(use_enable mongodb exporting-mongodb) \
+ $(use_enable prometheus exporting-prometheus-remote-write) \
$(use_enable xen plugin-xenstat) \
$(use_enable cpu_flags_x86_sse2 x86-sse) \
$(use_with compression zlib)