summaryrefslogtreecommitdiff
path: root/net-analyzer/net-snmp/net-snmp-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /net-analyzer/net-snmp/net-snmp-99999999.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'net-analyzer/net-snmp/net-snmp-99999999.ebuild')
-rw-r--r--net-analyzer/net-snmp/net-snmp-99999999.ebuild42
1 files changed, 18 insertions, 24 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-99999999.ebuild b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
index c6deae576b94..66e5dca50e31 100644
--- a/net-analyzer/net-snmp/net-snmp-99999999.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
@@ -13,7 +13,7 @@ inherit autotools distutils-r1 eutils git-r3 perl-module systemd
DESCRIPTION="Software for generating and retrieving SNMP data"
HOMEPAGE="http://www.net-snmp.org/"
-EGIT_REPO_URI="https://github.com/net-snmp/net-snmp"
+EGIT_REPO_URI="https://git.code.sf.net/p/net-snmp/code"
SRC_URI="
https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-3.tar.xz
"
@@ -22,38 +22,34 @@ SRC_URI="
LICENSE="HPND BSD GPL-2"
SLOT="0/35"
KEYWORDS=""
-IUSE="
- X bzip2 doc elf kmem ipv6 libressl lm-sensors mfd-rewrites minimal mysql
- netlink pcap pci perl python rpm selinux smux ssl tcpd ucd-compat zlib
-"
+IUSE="X bzip2 doc elf kmem ipv6 libressl lm_sensors mfd-rewrites minimal mysql netlink pci perl python rpm selinux smux ssl tcpd ucd-compat zlib"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
rpm? ( bzip2 zlib )
"
COMMON_DEPEND="
- bzip2? ( app-arch/bzip2 )
- elf? ( dev-libs/elfutils )
- lm-sensors? ( sys-apps/lm-sensors )
- mysql? ( dev-db/mysql-connector-c:0= )
- netlink? ( dev-libs/libnl:3 )
- pcap? ( net-libs/libpcap )
- pci? ( sys-apps/pciutils )
- perl? ( dev-lang/perl:= )
- python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )
- rpm? (
- app-arch/rpm
- dev-libs/popt
- )
ssl? (
!libressl? ( >=dev-libs/openssl-0.9.6d:0= )
libressl? ( dev-libs/libressl:= )
)
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ rpm? (
+ app-arch/rpm
+ dev-libs/popt
+ )
+ bzip2? ( app-arch/bzip2 )
zlib? ( >=sys-libs/zlib-1.1.4 )
+ elf? ( dev-libs/elfutils )
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ pci? ( sys-apps/pciutils )
+ lm_sensors? ( sys-apps/lm_sensors )
+ netlink? ( dev-libs/libnl:3 )
+ mysql? ( dev-db/mysql-connector-c:0= )
+ perl? ( dev-lang/perl:= )
"
DEPEND="
${COMMON_DEPEND}
@@ -72,7 +68,6 @@ S=${WORKDIR}/${P/_p*/}
RESTRICT=test
PATCHES=(
"${FILESDIR}"/${PN}-5.7.3-include-limits.patch
- "${FILESDIR}"/${PN}-5.8-pcap.patch
"${FILESDIR}"/${PN}-5.8-tinfo.patch
)
@@ -101,7 +96,7 @@ src_prepare() {
src_configure() {
# keep this in the same line, configure.ac arguments are passed down to config.h
local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail etherlike-mib/dot3StatsTable"
- use lm-sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
+ use lm_sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
use smux && mibs="${mibs} smux"
# Assume /etc/mtab is not present with a recent baselayout/openrc (bug #565136)
@@ -118,7 +113,6 @@ src_configure() {
$(use_with kmem kmem-usage) \
$(use_with mysql) \
$(use_with netlink nl) \
- $(use_with pcap) \
$(use_with pci) \
$(use_with perl perl-modules INSTALLDIRS=vendor) \
$(use_with python python-modules) \